Fuse blown? radio/clock/lighter won't work - Toyota Nation Forum : Toyota Car and Truck Forums
3rd & 4th Generation (19921996 & 19972001) Toyota Camry Discussion for years: 1992-1996 & 1997-2001 Topics of discussion range from fuel economy, safety, modifications, performance all involving America's favorite family car, the Toyota Camry.

 
LinkBack Thread Tools Display Modes
#1 Old 03-20-2009, 07:33 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Fuse blown? radio/clock/lighter won't work

Hey guys, i think it's kinda my fault maybe.. i turned off the car while my mp3 player was hooked up.. dunno and now radio, clock and lighter will not work..

Which fuse do I look for and where is it located? What could be wrong?

Thanks.
jakep99 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-20-2009, 08:17 PM
TN Post Wh*re
 
Join Date: Jun 2006
Location: PNW
Posts: 6,403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 13 Times in 12 Posts
iTrader Score: 0 reviews
Cig/Radio
toyomoho is offline  
#3 Old 03-20-2009, 08:49 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Is that located beside the steering wheel or in the realay box under the hood?
jakep99 is offline  
#4 Old 03-20-2009, 09:04 PM
Senior TN Member
 
Join Date: Dec 2005
Location: Cali
Posts: 1,297
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 13 Times in 13 Posts
iTrader Score: 0 reviews
check both

although whenever i come across a blown radio/cig fuse, the one under the hood is the one that was blown

Last edited by abew330; 03-20-2009 at 09:06 PM.
abew330 is offline  
#5 Old 03-20-2009, 09:20 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
The one under the hood is the one with 15 on it? :S
There are no labels...
jakep99 is offline  
#6 Old 03-21-2009, 01:27 AM
New TN User
 
Join Date: Jan 2009
Location: Anchorage, ak
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Not the 15, it should be a 20amp labeled DOME. check the underside of the top of the fuse box, it should have labels. If not that, then check behind the change tray by the drivers left leg.
mobj92 is offline  
#7 Old 03-21-2009, 01:30 AM
New TN User
 
ckyalliance222's Avatar
 
Join Date: Aug 2008
Location: PA
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
dome light fuse, under hood in the skinny fuse box behind the battery on tjhe gen4's

:hypnosis:~Chaos Brings Order~:hypnosis:
ckyalliance222 is offline  
#8 Old 03-21-2009, 01:00 PM
I'm a Mac
 
zoni's Avatar
 
Join Date: Oct 2002
Location: Southington, Connecticut
Posts: 4,062
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 2 reviews
when you are looking for advice on this forum, always list what year your car is and anything else pertaining to the problem...

i know for gen 3 it is the cig/radio fuse in the drivers kick panel
zoni is offline  
#9 Old 03-21-2009, 02:20 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
It's a 92 camry LE...
jakep99 is offline  
#10 Old 03-21-2009, 03:47 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
I checked the kickback, there is a 20amp fuse, but it doesn't look blown out. Also, the light is working, so I don't think it's the dome fuse at fault. What other fuse should I look at, again, no labels anywhere (under the hood nor kickback panel.
jakep99 is offline  
#11 Old 03-21-2009, 03:59 PM
Do not buy from
 
Join Date: Jun 2008
Location: 3ZC
Posts: 1,898
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
iTrader Score: 2 reviews
Lucky for you I happen to be hacking up my system this weekend. The only 20amp fuse should be there is the one for wiper. For your symtom (radio, clock, lighter and possible mirror), I bet my money on the 15 amp radio fuse.

Zviator is offline  
#12 Old 03-21-2009, 04:26 PM
New TN User
 
Join Date: Jul 2008
Location: ny
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Thanks dude, will check again!!

edit: worked! thanks bud

Last edited by jakep99; 03-21-2009 at 05:33 PM.
jakep99 is offline  
#13 Old 06-30-2009, 10:34 AM
New TN User
 
Join Date: Jun 2009
Location: South Florida
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I have a similar problem in my 1996 camry le. I am trying to install an aftermarket radio which i got on eBay. I got all the diagrams amd connected everything with butt-splice crimps instead of a wire harness. I tried to turn on the radio but had no power. I also noticed the clock and the dome light power were out. However, the cigarette lighter is still working fine. I even undid the wires and wired it again and the same problem occurred. Any suggestions? I thought it might be the fuse, but the cigarette lighter is on the same fuse? Please help if you know anything on the subject.
likemike277 is offline  
#14 Old 07-02-2009, 12:20 PM
I'm a Mac
 
zoni's Avatar
 
Join Date: Oct 2002
Location: Southington, Connecticut
Posts: 4,062
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 2 reviews
DOME fuse...
zoni is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Camry and Solara Forum > 3rd & 4th Generation (19921996 & 19972001)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome