Check Engine Light-Loose Gas Cap-Gen 4.5 - Toyota Nation Forum : Toyota Car and Truck Forums
3rd & 4th Generation (19921996 & 19972001) Toyota Camry Discussion for years: 1992-1996 & 1997-2001 Topics of discussion range from fuel economy, safety, modifications, performance all involving America's favorite family car, the Toyota Camry.

Reply
 
LinkBack Thread Tools Display Modes
#1 Old 05-21-2004, 08:57 AM
Official TN Member
 
Join Date: Sep 2003
Location: michigan
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Question Problem solved-Check Engine Light-Problem Solved!!

I have a 2000 Camry with a V6 and automatic transmission. I have about 38,000 miles on it. Recently, my check engine light came on. I did a search in the Camry Forum and found many threads. I got found some good advice about going to AutoZone so they could diagnose the problem for free. AutoZone told me my gas cap wasn't tightened enough at my last fill-up. The guy at AutoZone re-tightened my cap and re-set the ECU. The check engine light was gone. After a couple of days it came back on. I went back to AutoZone and they told me it was the cap again. We removed and then tightened the gas cap. The ECU was reset. Today I was driving to work and the light came on again. I have a feeling that if I go to AutoZone they will tell me that the scanner shows a code for a loose gas cap, again. Does anyone have any thoughts on what could be causing my problem? I could see having a loose gas cap once, but not three times.

Last edited by haa21; 10-05-2004 at 06:25 AM.
haa21 is offline  
Sponsored Links
Advertisement
 
#2 Old 05-21-2004, 09:08 AM
The Greatest
 
Join Date: Dec 2003
Location: Minnesota
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 4 reviews
The gas tank is pressurized. The problem should go away in like a week if you tighten it.

Do a search. I started a thread about how gas tanks are pressurized before.
CamNub is offline  
#3 Old 05-21-2004, 09:23 AM
Official TN Member
 
Join Date: Sep 2003
Location: michigan
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
CamNub-

The cap was tightened. The computer was re-set. Several days passed. The light came on again. The cap was still tight. The cap was re-tighted anyway. The computer was re-set again. 4 days have passed and now the light is on again. It has already been over a week. Are you saying that even after the supposed problem is rectified and the computer is re-set, the check engine light will still come on? Your thread states that the light will go away in 8 days on its own. My situation is different as I had the ECU re-set. The light was gone and came back. AutoZone told me that when the light goes away the error code is still in the computer if the computer is not re-set.

Last edited by haa21; 05-21-2004 at 09:53 AM.
haa21 is offline  
#4 Old 05-21-2004, 10:37 AM
Camry Freak
 
98CamryLE's Avatar
 
Join Date: Mar 2004
Location: SE Wisconsin
Posts: 818
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 0
Thanked 16 Times in 13 Posts
iTrader Score: 0 reviews
try buying a new gas cap. Just buy the one at autozone. It's like 6 bucks.
98CamryLE is offline  
#5 Old 05-21-2004, 11:27 AM
The Greatest
 
Join Date: Dec 2003
Location: Minnesota
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 4 reviews
Just erasing/resetting ur ECU shouldn't solve ur problem...
Its just hiding the fact that you have a problem...

Did this problem just randomly come up or did you not tighten ur cap very well? If its random, either take it to the dealer or get a new cap..
CamNub is offline  
#6 Old 05-21-2004, 01:30 PM
Official TN Member
 
Join Date: Sep 2003
Location: michigan
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
98CamryLE-

Thanks. I will try getting a new cap. Perhaps mine has lost it's ability to hold the pressure.

Does anyone else have any ideas in addition to getting a new cap??

Thanks.
haa21 is offline  
#7 Old 05-21-2004, 09:27 PM
Senior TN Member
 
Join Date: Sep 2003
Location: San Diego CA, Glen Cove NY,Fairford UK,Cedar Rapids, IA
Posts: 1,338
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 106 Times in 100 Posts
iTrader Score: 0 reviews
You should hear an audible "click" when the cap is tightened properly. You might also check your charcoal canister for cracked, loose or disconnected vacuum hoses. I believe there was a TSB about factory installed malformed crimped hoses on some models that caused the error code you get.

It worked fine until I fixed it!
csaxon is offline  
#8 Old 05-21-2004, 11:51 PM
The Greatest
 
Join Date: Dec 2003
Location: Minnesota
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 4 reviews
Re: Check Engine Light-Loose Gas Cap-Gen 4.5

Quote:
Originally posted by haa21
I did a search in the Camry Forum and found many threads. I got found some good advice about going to AutoZone so they could diagnose the problem for free.
Oh sorry if i offended you when i told you to search...I just skimmed thru your post..

Have you been in any accidents or anythin lately?
CamNub is offline  
#9 Old 05-22-2004, 12:52 AM
DJModifyd
 
alex's Avatar
 
Join Date: Apr 2002
Location: North Dakota
Posts: 1,492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 1 reviews
my CEL came on in my 4runner.......i thought it was the gas cap as well........but my fuel system was actually running lean.....i had deposits on my MAF.......cleaned that off and now it works fine

so check that out....maybe its running lean for some reason
alex is offline  
#10 Old 05-22-2004, 10:02 AM
Mitsubishi Diamante Owner
 
CDub LXi's Avatar
 
Join Date: May 2004
Location: North Nashville, TN
Posts: 1,743
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 1 reviews
Sounds to me like it's the cap itself or possibly the tank system. Since you're retightening the cap and resetting the ecu only to have it come back on, somehow it's losing pressurization. Try the replacement cap and if it still happens I'd just take it to the dealership.
CDub LXi is offline  
#11 Old 05-24-2004, 05:40 AM
Official TN Member
 
Join Date: Sep 2003
Location: michigan
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Alex-

What is the MAF?


Again, I want to thank everyone for their replies!
haa21 is offline  
#12 Old 05-24-2004, 11:41 AM
New TN User
 
Join Date: May 2004
Location: Northeastern PA
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Check Engine Codes

I doubt it is a problem with the gas cap. Autozone gets a code when they connect the OBD II scanner. I would be willing to bet it may be one or both of these codes
P0441 EVAP Control System Improper Purge Flow.
P0446 EVAP Control System Vent Control.
There are many things that could cause these codes and a gas cap being on of them. It also could be a vacuum leak, canister, or a solenoid not functioning properly. I have the same problem with my '99 Solara. When you find the fix, let me know.
ttreat is offline  
#13 Old 05-24-2004, 12:13 PM
Official TN Member
 
Join Date: Jun 2002
Location: CT
Posts: 324
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: Check Engine Codes

Quote:
Originally posted by ttreat
I doubt it is a problem with the gas cap. Autozone gets a code when they connect the OBD II scanner. I would be willing to bet it may be one or both of these codes
P0441 EVAP Control System Improper Purge Flow.
P0446 EVAP Control System Vent Control.
There are many things that could cause these codes and a gas cap being on of them. It also could be a vacuum leak, canister, or a solenoid not functioning properly.
ttreat's right on the $$$. I had this same problem a few years back, what ended up working for me was to replace my Vacuum Switching Valve with the updated part. If you check out the FAQ (http://www.toyotanation.com/faq/download/gen4-tsb.pdf), I've put together a PDF of many Gen4 Camry TSBs, and the #s he references in his post P0441, P0446 are all there...

Troubleshooting the EVAP system is a pain, if you look through those TSBs you'll understand why. In my case I bought a new gas cap 1st, and after that didn't work, my next step was to see if any of the parts had been updated (which they had been). The original Toyota VSV had been replaced with an updated model, so I figured I'd give that a shot 1st. The part was around $50 from http://www.partznet.com (Conicelli Toyota - highly recommended)...

HTH -

DJ

Last edited by dj14901; 05-24-2004 at 12:18 PM.
dj14901 is offline  
#14 Old 05-24-2004, 12:41 PM
Phi
Whine Connoisseur
 
Phi's Avatar
 
Join Date: Jul 2001
Location: T-DOT
Posts: 6,583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 8 Times in 7 Posts
iTrader Score: 2 reviews
the VSV (Vacuum Switching Valve) problem rears it's ugly head again....dun dun dun

96-98 owners - did you get the letter?
Phi is offline  
#15 Old 05-25-2004, 12:53 PM
Official TN Member
 
Join Date: Sep 2003
Location: michigan
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
dj14901-

I checked out the FAQ you posted and decided that this looks really hard to change!!

What problems can result from having a bad VSV?
haa21 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Camry and Solara Forum > 3rd & 4th Generation (19921996 & 19972001)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome