Code U0100 U0101 - Toyota Nation Forum : Toyota Car and Truck Forums
5th & 6th Generation (2002-2006 & 2007-2011) Toyota Camry Discussion for years: 2002-2006 & 2007-2011 Topics of discussion range from fuel economy, safety, modifications, performance all involving America's favorite family car, the Toyota Camry.

 
LinkBack Thread Tools Display Modes
#1 Old 10-22-2011, 02:04 PM
New TN User
 
Join Date: Jul 2010
Location: Portland, OR
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Angry Code U0100 U0101

Hey all,

Last couple days have been experience these codes pop up. First time I took to auto-zone the guy told me there is no such thing as U codes... because his computer couldn't give him a explanation lol So doing a little research and...

DTC U0100 Lost Communication with Engine Control Module (ECM)

DTC U0101 Lost Communication with Transmission Control Module (TCM)

I did notice coming home from a long distance that the transmission was having trouble figuring out what gear it should be in and when shifted over to sport shift (automatic) it would recognize it at first but then would quickly go back to drive mode on dash.

The car is a 07 Camry SE v6 auto, it has 55k on the odometer. I haven't been able to find any good info on what could of caused it and/or any fixes that I could do before I take it to the dealer.
Bilbojankins is offline  
Sponsored Links
Advertisement
 
#2 Old 10-22-2011, 05:51 PM
Twin & (1 of 8)
 
Luna2's Avatar
 
Join Date: Mar 2007
Location: Greenbush, USA
Posts: 1,403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 23
Thanked 165 Times in 156 Posts
iTrader Score: 1 reviews
Quote:
Originally Posted by Bilbojankins View Post
Hey all,

Last couple days have been experience these codes pop up. First time I took to auto-zone the guy told me there is no such thing as U codes... because his computer couldn't give him a explanation lol So doing a little research and...

DTC U0100 Lost Communication with Engine Control Module (ECM)

DTC U0101 Lost Communication with Transmission Control Module (TCM)

I did notice coming home from a long distance that the transmission was having trouble figuring out what gear it should be in and when shifted over to sport shift (automatic) it would recognize it at first but then would quickly go back to drive mode on dash.

The car is a 07 Camry SE v6 auto, it has 55k on the odometer. I haven't been able to find any good info on what could of caused it and/or any fixes that I could do before I take it to the dealer.
The TCM is a pass through the ECM. Check all of your wiring for damage. Power-train warranty?


2011 XLE, I4, AT, Sliver, New May 2, 2010
MFG 02/25/2010
Accident w/frame damage, got rid of car.
No Toyota in possession, now.
Luna2 is offline  
#3 Old 10-22-2011, 07:03 PM
New TN User
 
Join Date: Jul 2010
Location: Portland, OR
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Got with a buddy and we went through the wiring testing ohm/voltage and using alldata instructions. Everything checked out ok. I have reset ecm and waiting to see if it comes back on. He seems to think its a bad ecm.
Bilbojankins is offline  
#4 Old 10-22-2011, 07:10 PM
Twin & (1 of 8)
 
Luna2's Avatar
 
Join Date: Mar 2007
Location: Greenbush, USA
Posts: 1,403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 23
Thanked 165 Times in 156 Posts
iTrader Score: 1 reviews
Quote:
Originally Posted by Bilbojankins View Post
Got with a buddy and we went through the wiring testing ohm/voltage and using alldata instructions. Everything checked out ok. I have reset ecm and waiting to see if it comes back on. He seems to think its a bad ecm.
Best of luck...
I hope it was an electronic "burp".


2011 XLE, I4, AT, Sliver, New May 2, 2010
MFG 02/25/2010
Accident w/frame damage, got rid of car.
No Toyota in possession, now.
Luna2 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Camry and Solara Forum > 5th & 6th Generation (2002-2006 & 2007-2011)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome