2012 radio - Toyota Nation Forum : Toyota Car and Truck Forums


» Auto Insurance
» Featured Product
Advertisement
Wheel & Tire Center

Go Back   Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Highlander Forum > 2nd Generation (2008-2013)

2nd Generation (2008-2013) Forum dedicated to the discussion of 2nd generation Toyota Highlanders.

ToyotaNation.com is the premier Toyota Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-13-2012, 09:28 PM   #1 (permalink)
New TN User
 
Join Date: Jan 2012
Location: TN
Posts: 30
Thanks: 1
Thanked 3 Times in 2 Posts
iTrader Score: 0 reviews
View HomerSaysDoh's Photo Gallery
2012 radio

Does anyone know what the blue connector is on the back of the factory radio? A518AW I'm trying to swap this into my 2010 but I get an XM "antenna error" after the install.
HomerSaysDoh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-13-2012, 09:46 PM   #2 (permalink)
Trd racer
 
Join Date: Sep 2010
Location: kennesaw ga
Posts: 449
Gameroom cash: $139550
Thanks: 67
Thanked 30 Times in 27 Posts
iTrader Score: 0 reviews
View tundrav8yamaha's Photo Gallery
Quote:
Originally Posted by HomerSaysDoh View Post
Does anyone know what the blue connector is on the back of the factory radio? A518AW I'm trying to swap this into my 2010 but I get an XM "antenna error" after the install.
are you taking about the round blue plug that's the xm antenna ?



Last edited by tundrav8yamaha; 11-13-2012 at 09:59 PM.
tundrav8yamaha is online now   Reply With Quote Quick reply to this message
Old 11-13-2012, 09:58 PM   #3 (permalink)
Official TN Member
 
Join Date: May 2012
Location: seattle
Posts: 313
Gameroom cash: $195650
Thanks: 21
Thanked 17 Times in 17 Posts
iTrader Score: 0 reviews
View cutienoua's Photo Gallery
I know this is obvious ,but do you have the external tuner module for sat ??
cutienoua is online now   Reply With Quote Quick reply to this message
Old 11-13-2012, 10:01 PM   #4 (permalink)
Trd racer
 
Join Date: Sep 2010
Location: kennesaw ga
Posts: 449
Gameroom cash: $139550
Thanks: 67
Thanked 30 Times in 27 Posts
iTrader Score: 0 reviews
View tundrav8yamaha's Photo Gallery
Quote:
Originally Posted by cutienoua View Post
I know this is obvious ,but do you have the external tuner module for sat ??
I have a 2011 and mine is built into the radio. Xm is standard on the 11 no external tuner that I know about. Now adapters from Vais tech they sell too company is Based in Denver Colorado and allows for Oem factory wiring to work on older systems.

Last edited by tundrav8yamaha; 11-13-2012 at 10:04 PM.
tundrav8yamaha is online now   Reply With Quote Quick reply to this message
Old 11-13-2012, 10:08 PM   #5 (permalink)
Official TN Member
 
Join Date: May 2012
Location: seattle
Posts: 313
Gameroom cash: $195650
Thanks: 21
Thanked 17 Times in 17 Posts
iTrader Score: 0 reviews
View cutienoua's Photo Gallery
Quote:
Originally Posted by tundrav8yamaha View Post
I have a 2011 and mine is built into the radio. Xm is standard on the 11 no external tuner that I know about. Now adapters from Vais tech they sell too company is Based in Denver Colorado and allows for Oem factory wiring to work on older systems.
great info.
at this point aftermarket radio makes more sense!
cutienoua is online now   Reply With Quote Quick reply to this message
Old 11-13-2012, 10:24 PM   #6 (permalink)
Trd racer
 
Join Date: Sep 2010
Location: kennesaw ga
Posts: 449
Gameroom cash: $139550
Thanks: 67
Thanked 30 Times in 27 Posts
iTrader Score: 0 reviews
View tundrav8yamaha's Photo Gallery
Quote:
Originally Posted by cutienoua View Post
great info.
at this point aftermarket radio makes more sense!
I'm not sure what you're aiming to do But you can actually make the adapter work to go with that radio.
Did Toyota have the xm plugs on the 2010 highlander on the roof. I know for 2011 that was standard.
tundrav8yamaha is online now   Reply With Quote Quick reply to this message
Old 11-13-2012, 11:01 PM   #7 (permalink)
New TN User
 
Join Date: Jan 2012
Location: TN
Posts: 30
Thanks: 1
Thanked 3 Times in 2 Posts
iTrader Score: 0 reviews
View HomerSaysDoh's Photo Gallery
My 2010 unit works fine but doesn't have the blue XM connector. The other plugs were a swap in the 2012 unit and I thought this would work. I guess XM is in the harness of the 2010 unit and separate for the 2012. I just like the is play, layout and longer song info of the 2012. Any ideas on hat adapter I need to make this work? Thanks for the replies so far.
HomerSaysDoh is offline   Reply With Quote Quick reply to this message
Old 11-19-2012, 06:32 PM   #8 (permalink)
New TN User
 
Join Date: Jan 2012
Location: TN
Posts: 30
Thanks: 1
Thanked 3 Times in 2 Posts
iTrader Score: 0 reviews
View HomerSaysDoh's Photo Gallery
Quote:
Originally Posted by tundrav8yamaha View Post
are you taking about the round blue plug that's the xm antenna ?


Any idea on the part number for the XM antenna? I'm still trying o get X M working with the swap
HomerSaysDoh is offline   Reply With Quote Quick reply to this message
Old 11-19-2012, 09:25 PM   #9 (permalink)
Official TN Member
 
Join Date: May 2012
Location: seattle
Posts: 313
Gameroom cash: $195650
Thanks: 21
Thanked 17 Times in 17 Posts
iTrader Score: 0 reviews
View cutienoua's Photo Gallery
xm radio doesn't sound that good! I had a rental car for the weekend with xm
then I switched to streaming pandora from ipad mini . I used a bluetooth adapter to go to rental car aux input
I was blown away by the sound quality.
with xm I tried all audio settings nothing was good.
I thought it must be the car audio system ,switching to pandora proved me wrong!
cutienoua is online now   Reply With Quote Quick reply to this message
Old 11-19-2012, 09:50 PM   #10 (permalink)
New TN User
 
Join Date: Jan 2012
Location: TN
Posts: 30
Thanks: 1
Thanked 3 Times in 2 Posts
iTrader Score: 0 reviews
View HomerSaysDoh's Photo Gallery
Never mind, I got it. Disconnected the antenna behind the dash that runs to the XM unit under the seat and plugged it into the new hu. Woohoo it works!
HomerSaysDoh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Highlander Forum > 2nd Generation (2008-2013)

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Nation Forum : Toyota Car and Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:35 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
ToyotaNation.com is an independent Toyota/Lexus enthusiast website. ToyotaNation.com is not sponsored by or in any way affiliated with Toyota Motor Sales, USA, Inc. The Toyota, Lexus and Scion names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.