Sunroof Noise - Toyota Nation Forum : Toyota Car and Truck Forums
2nd Generation (2008-2013) Forum dedicated to the discussion of 2nd generation Toyota Highlanders.

 
LinkBack Thread Tools Display Modes
#1 Old 11-28-2012, 09:51 AM
Official TN Member
 
AdamsCL's Avatar
 
Join Date: Dec 2008
Location: Indy
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
USA Sunroof Noise

I recently opened the sunroof on my HL and discovered it is making a loud thud noise as it drops down before sliding back. It sounds like something is rubbing. It seems to raise and lower into the vent position fine and had no previous issues until now. For what it's worth, this is the first time it has been opened in roughly a year. I know I should probably open it more often, and I'm wondering if not opening it regularly may have caused this issue. Any thoughts from those who have experienced this would be appreciated.

2008 Highlander Limited AWD, Classic Silver Metallic, Ash Leather, SmartKey, JBL/Bluetooth, Tow Package, Debadged Power Rear Door - Accessories: Toyota VIP Remote Start, Mud Guards, Valor Exhaust Tip
AdamsCL is offline  
Sponsored Links
Advertisement
 
#2 Old 11-28-2012, 10:19 AM
Official TN Member
 
Join Date: Apr 2011
Location: Chelmsford MA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
I had a similar problem on my "11" about a year ago. It was easliy resolved with an adjustment by the dealer. There was a timing/sychronization issue where the roof was starting to retract before it had lowered sufficiently. It has been trouble free since!
shellback is offline  
#3 Old 11-28-2012, 12:31 PM
Official TN Member
 
Join Date: Mar 2010
Location: Canada
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 16
Thanked 6 Times in 6 Posts
iTrader Score: 0 reviews
Same with my 09. Dealership adjusted the moonroof for the third time already. It is better than before but still binds with the roof when I try to open it. I have to remind the service manager that it still needs a little fine tuning when I go there for the emblems of the tailgate.

2009 Sandy Beach Metallic Highlander Sport V6 AWD
2011 Pyrite Mica Rav4 Limited I4 4WD ( wife's )
mikmabz is offline  
#4 Old 11-28-2012, 02:34 PM
Official TN Member
 
AdamsCL's Avatar
 
Join Date: Dec 2008
Location: Indy
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
USA

Thank-you for the replies. I don't know if getting a new battery last week would have altered any of the sunroof settings. I want to get it repaired but I'm reluctant to have it looked at after reading that some have experienced small leaks or it had become worse after adjustment. Does the dealer have to drop the headliner to make adjustments? Thanks!

2008 Highlander Limited AWD, Classic Silver Metallic, Ash Leather, SmartKey, JBL/Bluetooth, Tow Package, Debadged Power Rear Door - Accessories: Toyota VIP Remote Start, Mud Guards, Valor Exhaust Tip
AdamsCL is offline  
#5 Old 11-28-2012, 04:51 PM
Official TN Member
 
DeWat's Avatar
 
Join Date: Nov 2007
Location: Southern Maryland
Posts: 569
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 17
Thanked 21 Times in 20 Posts
iTrader Score: 0 reviews
My '08's sunroof would "pop" like it was breaking loose from being hung up when opening during certain times of the year. I just can't remember if it was winter or summer, but it was climate related and would only happen during that season. If memory serves me correctly, that has been discussed here before.

EDIT: Just found one of the threads that I was referring to at http://www.toyotanation.com/forum/12...hud-noise.html, but I thought there was a post somewhere where someone related it to climate, which put me at ease when I was hearing it.

2012 Toyota Highlander Limited AWD, Blizzard Pearl (His)
2011 Toyota Avalon, Magnetic Grey Exterior (Hers)
2013 Winnebago Vista 35B Motorhome



Last edited by DeWat; 11-28-2012 at 04:56 PM.
DeWat is offline  
#6 Old 11-28-2012, 05:46 PM
Official TN Member
 
Join Date: Nov 2009
Location: so cal
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 9 Times in 9 Posts
iTrader Score: 0 reviews
If you have disconnected the battery it needs to be initalized. Make sure the moon roof is fully closed, then turn on the ingition switch, push and hold the tilt up switch untill the moon roof reaches the full tilt up position then, release the switch. Push and hold the tilt up switch again. after approx.10 seconds moon roof will begin to initalize.hold switch on and the moon roof will tilt down, slide open, slide close and stop at the fully closed position. Thats it. your done. should work better now.
toytec is offline  
#7 Old 11-28-2012, 05:56 PM
Senior TN Member
 
Join Date: Aug 2007
Location: SaN Diego
Posts: 1,513
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 24 Times in 24 Posts
iTrader Score: 2 reviews
My roof make a pooping noise once in awhile.
LoudCamry is offline  
#8 Old 11-29-2012, 01:34 AM
Official TN Member
 
Join Date: Mar 2010
Location: Canada
Posts: 157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 16
Thanked 6 Times in 6 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by AdamsCL View Post
Thank-you for the replies. I don't know if getting a new battery last week would have altered any of the sunroof settings. I want to get it repaired but I'm reluctant to have it looked at after reading that some have experienced small leaks or it had become worse after adjustment. Does the dealer have to drop the headliner to make adjustments? Thanks!
I am not really sure if they did drop the headliner. I will ask the service manager next time and I will let you know.

2009 Sandy Beach Metallic Highlander Sport V6 AWD
2011 Pyrite Mica Rav4 Limited I4 4WD ( wife's )
mikmabz is offline  
#9 Old 11-30-2012, 09:37 AM
Official TN Member
 
AdamsCL's Avatar
 
Join Date: Dec 2008
Location: Indy
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by toytec View Post
If you have disconnected the battery it needs to be initalized. Make sure the moon roof is fully closed, then turn on the ingition switch, push and hold the tilt up switch untill the moon roof reaches the full tilt up position then, release the switch. Push and hold the tilt up switch again. after approx.10 seconds moon roof will begin to initalize.hold switch on and the moon roof will tilt down, slide open, slide close and stop at the fully closed position. Thats it. your done. should work better now.
Thanks for all the replies! I will try the above mentioned process and see if it fixes the problem.

2008 Highlander Limited AWD, Classic Silver Metallic, Ash Leather, SmartKey, JBL/Bluetooth, Tow Package, Debadged Power Rear Door - Accessories: Toyota VIP Remote Start, Mud Guards, Valor Exhaust Tip
AdamsCL is offline  
#10 Old 09-18-2013, 02:09 PM
New TN User
 
Join Date: Aug 2013
Location: Warsaw
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by toytec View Post
If you have disconnected the battery it needs to be initalized. Make sure the moon roof is fully closed, then turn on the ingition switch, push and hold the tilt up switch untill the moon roof reaches the full tilt up position then, release the switch. Push and hold the tilt up switch again. after approx.10 seconds moon roof will begin to initalize.hold switch on and the moon roof will tilt down, slide open, slide close and stop at the fully closed position. Thats it. your done. should work better now.
Just tried that in my 08 and still experiencing the same loud thud noise when it slides in
adamkpl is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Highlander Forum > 2nd Generation (2008-2013)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome