Sunroof won't open....loud thud noise - Toyota Nation Forum : Toyota Car and Truck Forums

Highlander 2nd Generation (2008-2013) Forum dedicated to the discussion of 2nd generation Toyota Highlanders.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 Old 08-23-2011, 10:16 PM Thread Starter
New TN User
 
13ducati13's Avatar
 
Join Date: Dec 2008
Location: Providence
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Sunroof won't open....loud thud noise

My car has 36,400 miles...of course 400 over the warranty. Today the sunroof made a thud noise when it opened but it did in fact open. A few hours later when I was returning home I tried to open the sunroof and it would compress like it was going to open and then would make a very loud thud but not open.

Any ideas?

Do you think the dealership would still honor the warranty being it's so close to 36K miles?

'08 HL Sport 4WD, classic silver metallic, ash leather
'96 T100, 4WD, extended cab, black, 130K miles
13ducati13 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 08-25-2011, 10:14 AM
keep your boost up
 
cp44's Avatar
 
Join Date: Apr 2007
Location: VA
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 1
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
funny thing is my sunroof on my 07 Camry does the same thing, i think its the rubber weather stripping sticking to the roof that causing that loud thud.

Ask the dealer and work something out with them but you my have to fight with them a little.

:\Documents and Settings\aaron.wu\Desktop\LIGHTS.jpg

A wise man once said "If ignorance is bliss and patience is a virture, you'll have a good life if your dumb enough to wait"
cp44 is offline  
post #3 of 20 Old 11-02-2011, 07:09 PM
New TN User
 
bamafan76's Avatar
 
Join Date: Jan 2011
Location: New Orleans
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Searching for this topic and found this thread. For the past couple of weeks, my wife's '11 Higlander sunroof has been sticking as well. There are no problems with the up and down, it happens when trying to open it. The problem makes a thud noise when trying to go down to slide back, sometimes it opens, sometimes it doesn't. When standing above the vehicle while attempting to open it, you can see the actual roof line try and drop when it attempts to open. If it does open and when trying to close it, you can see that when it seals the roof line comes up, almost seeming as though the seal is so tight it pulls on the roof.

Anyone else experiencing this? Of course it's under warranty, so I will be bringing it in, just thought I'd post here first.

bamafan76 is offline  
Sponsored Links
Advertisement
 
post #4 of 20 Old 11-02-2011, 08:05 PM
Official TN Member
 
Join Date: Apr 2011
Location: Chelmsford MA
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
I have just experienced the same thud while opening the roof on my "11". Roof opens ok but the noise is disconcerting.
shellback is offline  
post #5 of 20 Old 11-03-2011, 02:28 PM
Ube Ice Cream
 
Join Date: Jun 2011
Location: MD
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yup, mine makes this sound too just like bamafans. It made me think that something broke up there the first time.
ingko is offline  
post #6 of 20 Old 11-04-2011, 04:14 PM
Official TN Member
 
Join Date: Apr 2011
Location: Chicago
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Mine did that but it opened after the thud, what happened is that it would not go down far enough before moving back, had a friend of mine adjust it for me, he is a car mechanic, opens and closes nice and quiet now
GregC6 is offline  
post #7 of 20 Old 11-09-2011, 11:26 AM
Official TN Member
 
Join Date: Apr 2011
Location: Chelmsford MA
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
Roof problem solved today. Dealer suspected that it was not set correctly at the factory. I was in and out in under an hour . Roof action is now smooth and quiet.
shellback is offline  
post #8 of 20 Old 11-09-2011, 11:28 AM
Official TN Member
 
Join Date: Apr 2011
Location: Chicago
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by shellback View Post
Roof problem solved today. Dealer suspected that it was not set correctly at the factory. I was in and out in under an hour . Roof action is now smooth and quiet.
I think this was an issue with my car, old lady had it before me and she never opened it lol
GregC6 is offline  
post #9 of 20 Old 11-09-2011, 11:50 AM
Do you feel lucky?
 
TrailDust's Avatar
 
Join Date: Mar 2008
Location: Kalifornication
Posts: 29,269
Mentioned: 51 Post(s)
Tagged: 0 Thread(s)
Quoted: 4188 Post(s)
Thanks: 3,450
Thanked 6,947 Times in 4,856 Posts
Lifetime Supreme Member
iTrader Score: 1 reviews
Quote:
Originally Posted by shellback View Post
Roof problem solved today. Dealer suspected that it was not set correctly at the factory. I was in and out in under an hour . Roof action is now smooth and quiet.
Excellent! Thank you for the update....



-------------------------


2008 Highlander Base 4WD
2002 Avalon XL
1987 Suzuki Samurai 4X4 - Treading where no Jeep can follow....
TrailDust is offline  
post #10 of 20 Old 11-18-2011, 03:19 PM
New TN User
 
bamafan76's Avatar
 
Join Date: Jan 2011
Location: New Orleans
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by shellback View Post
Roof problem solved today. Dealer suspected that it was not set correctly at the factory. I was in and out in under an hour . Roof action is now smooth and quiet.
Glad to hear yours is fixed. I took mine to the dealer last Saturday to have it checked. After a couple of hours they called and said it was good. My wife picked it up, brought it home and after I looked at it, I knew something wasn't right as the driver corner sat lower than the passenger. Sure enough with a little hose water, leaks. Brought it back and after an hour said it is good now. This past Wednesday it rained, and it leaked. Brought it back, they claimed the shop foreman removed the glass, inspected everything and it should be good. They also claimed that even though all is good, sunroofs do not seal 100%. They claim it is normal to see a slight drip from the inside but it is draining in the channel and not in the car and used 3 cars off the lot with sunroofs to check and they all did the same thing.

So my question is, has anyone else noticed either when it rains or after a car wash a few drips of water can be seen from inside the car when looking toward the back of the sunroof? Just curious if they were telling me the truth.

bamafan76 is offline  
post #11 of 20 Old 11-18-2011, 04:47 PM
Official TN Member
 
Join Date: Apr 2011
Location: Chelmsford MA
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
Sorry to hear of your difficulties. I have had no evidence of any leakage from the roof after washing or very heavy rain. Did your roof leak before you brought it in? Ive had similar roofs on several Saabs and had no leakage issues for over 20 years. The Toyota roof should at least as good.
shellback is offline  
post #12 of 20 Old 11-18-2011, 05:55 PM
New TN User
 
bamafan76's Avatar
 
Join Date: Jan 2011
Location: New Orleans
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I couldn't say whether or not there was a little drip prior to because I never had a reason to look. It's not leaking persay into the car; however, if you were to run it through a car wash like they did at the dealership, you can see it leaking a tiny bit through the gasket. It doesn't appear to be leaking into the car itself...I dunno.

I'm debating on taking it to another dealership here and letting them look at it.

bamafan76 is offline  
post #13 of 20 Old 11-18-2011, 06:04 PM
Official TN Member
 
Join Date: Apr 2011
Location: Chelmsford MA
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
It certainly would not hurt to get a second opinion!
shellback is offline  
post #14 of 20 Old 11-19-2011, 12:41 AM
Official TN Member
 
Join Date: Apr 2011
Location: Chicago
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
try to lubricate the rubber seals, that helps sometimes
GregC6 is offline  
post #15 of 20 Old 11-19-2011, 01:32 AM
Resident Nutcase
 
sweeneyp's Avatar
 
Join Date: Apr 2010
Location: Nashville, TN
Posts: 11,885
Blog Entries: 8
Mentioned: 59 Post(s)
Tagged: 1 Thread(s)
Quoted: 1178 Post(s)
Thanks: 642
Thanked 1,809 Times in 1,438 Posts
Lifetime Supreme Member
Garage
iTrader Score: 0 reviews
bamafan76, you may want to try another dealership, a 2nd opinion is never a bad thing.... the ONLY time mine has ever let water through is during a car wash that has a VERY high pressure wash (I mean higher than most) spraying directly on the sunroof, I will feel a very slight mist through the sunroof. Otherwise I've never had moisture come through.

Click Here for the Full List of Mods Done to My Highlander ---->>> 2008 FWD Highlander Limited
sweeneyp is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Highlander Forum > Highlander 2nd Generation (2008-2013)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Back