corolla with code p0500 only when smogged - Toyota Nation Forum : Toyota Car and Truck Forums


» Auto Insurance
» Featured Product
Advertisement
Wheel & Tire Center

Go Back   Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Corolla and Matrix Forum > 8th Generation (1998-2002)

8th Generation (1998-2002) Specific discussion of the 8th generation

ToyotaNation.com is the premier Toyota Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-25-2011, 07:53 PM   #1 (permalink)
New TN User
 
Join Date: Aug 2011
Location: san diego
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View djgs's Photo Gallery
corolla with code p0500 only when smogged

Hey guys, i did a quick search for whats happening to my car but coundnt find anything similar.

Well first off the corolla has no MIL on at all. It did have a p0420(low catalytic effeciency) but got that fixed. So i thought it was ready for smog. Cleared the code. Never came back. Car finished doing its driving cycle and got the green light from the odb2 scanner.

So i took it to the smog test place and when they did the 15 mph test the MIL came on. p0500. vehicle speed sensor malfuncion. did some reasearch and most of the time you just reset the code and it never comes back. ok. cleared the code. finished doing its driving cycle and got the green light on the odb 2 scanner. took it to the smog test and bam! agian p0500 at the 15 mph test.

Ive driven this car for hundreds of miles and that code never showed up. only when its on the smog test place. I pulled up the Freeze frame form the odb 2 scanner and it said 0 mph at @ 2000 rmp. my speedometer works perfect. it never acts weird or dies or anything. it works perfect. what can cause the sensor to read 0 mph when its at the smog test. Tomorrow im going to lift the car and rev it up to 2000 rpm and see if the speedometer works when only the front tires are spining. Any help or advice would be awesome for me.

One detail that i dont thing is that important but you never know, is that the cluster was changed some time ago by the previous owner. he said it got fried. this one works perfect though with no glitches watsoever.

Thanks..
djgs is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Corolla and Matrix Forum > 8th Generation (1998-2002)

Bookmarks

Tags
p0500 , vehicle speed sensor , vss

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Nation Forum : Toyota Car and Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
ToyotaNation.com is an independent Toyota/Lexus enthusiast website. ToyotaNation.com is not sponsored by or in any way affiliated with Toyota Motor Sales, USA, Inc. The Toyota, Lexus and Scion names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.