99 Corolla No Start, 15AMP EFI Fuse Blown - Toyota Nation Forum : Toyota Car and Truck Forums
8th Generation (1998-2002) Specific discussion of the 8th generation

 
LinkBack Thread Tools Display Modes
#1 Old 09-29-2011, 05:32 PM
New TN User
 
Join Date: Sep 2011
Location: NY
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
99 Corolla No Start, 15AMP EFI Fuse Blown

I Started my 99 corolla VE this morning. Drove twenty feet and the car died. I notice a burnt electrical smell inside. Found a blown 15A EFI fuse inside engine fuse box. Replaced blown 15A EFI with new 15A fuse, new fuse did not blow, still no start condition. When turning the key the check engine light does not illuminate. Also something unusual was the big rain storm twenty minutes prior to driving the car.

Last edited by edbo; 10-02-2011 at 12:08 PM.
edbo is offline  
Sponsored Links
Advertisement
 
#2 Old 10-01-2011, 01:11 PM
New TN User
 
Join Date: Sep 2011
Location: NY
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
99 corolla ECU fried

Checked the OBD for codes today. OBD tester would not register. Located the ECU and found a fried circuit board inside. One of diodes on the board was burnt.

Last edited by edbo; 10-02-2011 at 12:10 PM.
edbo is offline  
#3 Old 10-09-2011, 10:48 AM
New TN User
 
Join Date: Sep 2011
Location: NY
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Installed new ECU, car started but had OBD code P0105. Installed new MAP sensor no codes car runs fine.

Items replaced: 15A EFI fuse, ECU and MAP sensor
edbo is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Corolla and Matrix Forum > 8th Generation (1998-2002)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome