'03 Corolla A/C problem - Toyota Nation Forum : Toyota Car and Truck Forums
9th Gen Corolla/1st Gen Matrix (2003-2008) 9th generation Corolla and 1st generation Matrix discussion.

 
LinkBack Thread Tools Display Modes
#1 Old 06-29-2007, 03:47 PM
New TN User
 
Join Date: Jun 2007
Location: Texas
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
'03 Corolla A/C problem

My 2003 corolla A/C has been working intermittently the past few days. I determined that the clutch wasn't engaging. I played with the MG CLT relay, and it kicked in, but I'm not sure if that was just dumb luck. What are some of the different things that can prevent the relay from engaging the clutch? I put some refridgerant in the other day, but I still haven't taken any pressure readings.(I'm not sure where to take them, and what pressure is normal.) When the A/C is engaged it's nice and cold. I just would like to try and isolate the problem a little more before spending too much money chasing the problem around. A new relay should only be $60, but I'm not 100% sure that's it.

I'm not sure how to jump the relay, so if someone could explain it might help.

Any suggestions would be greatly appreciated.
Jeff
adamsjef is offline  
Sponsored Links
Advertisement
 
#2 Old 06-29-2007, 04:01 PM
Resident asshole
 
Flashmn's Avatar
 
Join Date: Nov 2001
Location: Finland
Posts: 9,546
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 26 Times in 26 Posts
iTrader Score: 0 reviews
Quote:
I put some refridgerant in the other day, but I still haven't taken any pressure readings.(I'm not sure where to take them, and what pressure is normal.)
thats something you absolutely shouldnt do.

Some things that prevent the magnetic clutch from engaging:
1)Contact failure
2)too little pressure
3)too high pressure
4)wiring problem
5)Magnetic clutch relay faulty.
Flashmn is offline  
#3 Old 06-30-2007, 06:50 AM
Senior TN Member
 
retiredat44's Avatar
 
Join Date: Feb 2006
Location: Scio, Oregon
Posts: 1,589
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Thanks: 1
Thanked 22 Times in 21 Posts
iTrader Score: 0 reviews
Cool

go to http://acsource.com/ forums for best help with a/c:

http://www.acsource.net/acforum/
and ask your questions there..
retiredat44 is offline  
#4 Old 11-21-2007, 07:00 PM
New TN User
 
Join Date: Nov 2007
Location: US
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
It's probably too late, but I have the same problem, you can use the relay from the horn, it's almost the same(if not the same). I have switched mine with the MG CLT Relay and now the A/C is working fine.I have no horn for now, but I rather have the A/C.
Vladi is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Corolla and Matrix Forum > 9th Gen Corolla/1st Gen Matrix (2003-2008)

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Nation Forum : Toyota Car and Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome