2000 Celica Fuel Gauge stopped working, and ... - Toyota Nation Forum : Toyota Car and Truck Forums
Celica Forum Forum for all Toyota Celica discussion! Including the ST16x/18x/20x, and ZZT230/231.

 
LinkBack Thread Tools Display Modes
#1 Old 08-24-2010, 08:30 PM
New TN User
 
Join Date: Aug 2010
Location: EARTH
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Question 2000 Celica Fuel Gauge stopped working, and ...

In fact all these went out at once ...

* No Running Lights
* No Automatic Lights
* No Door Alarm
* Middle button on console wont lock/unlock doors
* Remote won't lock/unlock car
* No Gas Gauge
* No Seat Belt check light or alarm
* No Fuel Door open light
* Can't lock the trunk, haveto manually lock doors

Is this a relay problem ??? Only Code I get is something about Catalyst Imbalance!?!? Been a great car, no major work and 176,000 + miles.

Any ideas?
Thanks!

Rick
rickstgeorge is offline  
Sponsored Links
Advertisement
 
#2 Old 08-24-2010, 09:23 PM
TN Post Wh*re
 
Bitter's Avatar
 
Join Date: Sep 2006
Location: Near Chicago
Posts: 8,478
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 278 Post(s)
Thanks: 5
Thanked 570 Times in 534 Posts
iTrader Score: 0 reviews
Bitter is online now  
#3 Old 08-31-2010, 10:59 PM
New TN User
 
Join Date: Aug 2010
Location: EARTH
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Unhappy

Multi Fuse?

What is that?? And Where is it ???

Ps. I know where the two fuse boxes are.

Thanks!
rickstgeorge is offline  
#4 Old 09-21-2010, 11:33 AM
New TN User
 
Join Date: Sep 2010
Location: Jacksonville
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Same Problem

Hey rickstgeorge,

Did you ever figure out what was wrong with your car? I am having the exact same problems...
I've made sure all of the fuses in the car and under the hood are not blown. Hope you were able to fix the problem and if so please let me know what you did.
gec326fl is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Celica Forum

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Toyota Nation Forum : Toyota Car and Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome