A/C recharge help - Toyota Nation Forum : Toyota Car and Truck Forums

Yaris/Scion iA, Vitz and Echo Forum Discussion area for all the Toyota Yaris/Scion iA, Echo, and Vitz owners worldwide.

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-28-2012, 03:30 AM Thread Starter
New TN User
Join Date: Nov 2011
Location: Ohio
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
A/C recharge help

My 03 Echo has a semi-working A/C. It blows cool, but not cold. I suspect it's just low on refrigerant. 2 things:

1. Why does everything have leak-stop in it? I want refrigerant wih oil already added because it isn't a completely empty system, but all those mixed bottles also have leak stop in them. Is that stuff still bad for the car or am I just paranoid?

2. What is the proper low-side pressure after a charge?
Mentaluproar is offline  
Sponsored Links

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Yaris/Scion iA, Vitz and Echo Forum


User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome