2003 Echo Tail Lights and Dash lights not working - Toyota Nation Forum : Toyota Car and Truck Forums
Yaris, Vitz and Echo Forum Discussion area for all the Toyota Yaris and Echo owners worldwide.

 
LinkBack Thread Tools Display Modes
#1 Old 02-11-2010, 08:20 PM
New TN User
 
Join Date: Feb 2010
Location: Fort Wayne, Indiana
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
2003 Echo Tail Lights and Dash lights not working

The fuses are fine the bulbs are fine- the actual break lights work the head lights work- when we installed an aftermarket radio the dashlights and running tail lights stopped working - we changed all of the fuses and bulbs- something in the wiring is messed up- so do we need a whole new fuse panel or just new wires? any advice would be appreciated.
JenniferBuford is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Yaris, Vitz and Echo Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome