p0171 fault code on my toyota platz - Toyota Nation Forum : Toyota Car and Truck Forums
Yaris, Vitz and Echo Forum Discussion area for all the Toyota Yaris and Echo owners worldwide.

 
LinkBack Thread Tools Display Modes
#1 Old 03-03-2010, 06:15 AM
New TN User
 
Join Date: Mar 2010
Location: malta
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
European Union p0171 fault code on my toyota platz

hello there i'm new to this forum i do work as a mechanic but on older version cars that had carburettors,my problem is that my son got this toyota platz which has a fault on dasboard i diagnose with code reader and found it was p0171 code i renewed the fuel filter,replaced also the air flow sensor,but still on going uphill it show again then i switch off the car and shows again always going uphill can someone help.
joegetz is offline  
Sponsored Links
Advertisement
 
#2 Old 09-23-2010, 05:44 PM
New TN User
 
Join Date: Sep 2010
Location: New Zealans
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
P0171 uphill

Hi I had the same problem with the engine light coming on when going uphill, code P0171. I tried several things, cleaned the MAF, changed the air filter and spark plug but the problem was still there. I took it to a garage and they changed the oxygen sensor, checked for vacuum leaks, fuel pressure, bad earth to the MAF, adjusted the hot idle but the problem was still there. In the end I clean the MAF again and noted that there was a bit of play in the air filter housing. On one of the front bolts holding the air filter housing the rubber washer had been compressed and was not holding the corner of the filter housing firm. I put an extra rubber washer under the bolt to remove the play and the problem seems to be fixed. I have tested it for about 2 week with no sight of the light, prior to this the light came on daily. Hope this is of some help.
gbird is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Yaris, Vitz and Echo Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome