Engine Immobilizer Light - Toyota Nation Forum : Toyota Car and Truck Forums
2nd Generation (2005+) Discussion area for the 2nd generation of the Toyota Tacoma

 
LinkBack Thread Tools Display Modes
#1 Old 05-21-2008, 11:03 AM
New TN User
 
Join Date: Oct 2005
Location: honolulu
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Engine Immobilizer Light

Last night I was outside and noticed the engine immobilizer light on the dash flashes every 2 seconds. Seems to me it did not flash/blink that frequently previously. Is this normal? There are times I do not drive my truck for a week and wondering if this will drain the battery where I will not be able to start it.
itawes is offline  
Sponsored Links
Advertisement
 
#2 Old 05-21-2008, 11:07 AM
Senior TN Member
 
RTFM's Avatar
 
Join Date: Nov 2005
Location: Half Moon Bay, CA
Posts: 1,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 5
Thanked 79 Times in 74 Posts
iTrader Score: 0 reviews
Mine flashes a lot, don't know it its every two seconds. I've gone two weeks without driving mine without a problem. I've got an alarm that flashes as well, no problems.

06 DC LB, 4x4, Speedway , TRD Sport w/ Tow, JBL 6CD w/ Grom to IPod, Roof Rack, Weathertech bug deflector & floormats, Access LE tonneau, Hood Struts, Scangauge, Clifford 10.5x alarm, Homelink Mirror, Ultra Grinder Wheels, Toyo Open Country AT tires
RTFM is offline  
#3 Old 05-21-2008, 11:39 AM
98401
 
Join Date: Dec 2007
Location: Massachusetts
Posts: 193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 1 reviews
Yup, always flashes like that, at whatever duration. Will not drain bad.

Normal.
johnwill is offline  
#4 Old 05-21-2008, 05:34 PM
Banned
 
Join Date: Dec 2007
Location: Pocatello, Idaho
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Be lucky yours only flashes when your key is out of the ignition, for some reason mine is all messed up. My light flashes what seems to be a code with longer pauses and different blink speeds, but it is repeating a pattern. Ohh and that is when my key is in the ignition, when the key is out of the ignition it stays on steady. Going on 6 months now and still nothing from Toyota on how they are going to fix it. Original problem documented at 19,400 miles, now I have almost 24,000 miles and the light is extremely annoying when it is blinking and you are driving at night.....

Anyone have a clue as to what might have caused this. Ohh and it is not disabled cause the "dumb" keys won't start the truck, just the "smart" keys so it is still functioning...and it won't always communicate with Toyota's diagnostic computer either.... I think I just need a new immobilizer brain, but that is alot of cash and toyota is stalling to write that up as warranty, I am about down with the waiting though.... anyone have any ideas on what to do or how to fix or how to get it fixed....
mr.trd is offline  
#5 Old 05-22-2008, 01:00 PM
Senior TN Member
 
RTFM's Avatar
 
Join Date: Nov 2005
Location: Half Moon Bay, CA
Posts: 1,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 5
Thanked 79 Times in 74 Posts
iTrader Score: 0 reviews
Try this, looks like someone found the answer. Don't know for sure, as mine is fine.

http://www.tundrasolutions.com/forums/293674-post5/

Here's some troubleshooting guides you can give the dealer
http://www.customtacos.com/tech/file...06ta/04900.pdf
http://www.customtacos.com/tech/file...6ta/049004.pdf

All From (in case you need the solutions)
http://www.customtacos.com/tech/files/05FSM/repair.html

06 DC LB, 4x4, Speedway , TRD Sport w/ Tow, JBL 6CD w/ Grom to IPod, Roof Rack, Weathertech bug deflector & floormats, Access LE tonneau, Hood Struts, Scangauge, Clifford 10.5x alarm, Homelink Mirror, Ultra Grinder Wheels, Toyo Open Country AT tires

Last edited by RTFM; 05-22-2008 at 01:07 PM.
RTFM is offline  
#6 Old 05-22-2008, 03:36 PM
Banned
 
Join Date: Dec 2007
Location: Pocatello, Idaho
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Thanks man, I am going to go down to Toyota after work and put these papers in their face and tell them to fix it....the problem is is that my truck is used and I only got on black key and it is obviously the spare master key so we will see what it takes to get a main master key.
mr.trd is offline  
#7 Old 05-22-2008, 04:22 PM
New TN User
 
Join Date: May 2008
Location: NV
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by mr.trd View Post
Be lucky yours only flashes when your key is out of the ignition, for some reason mine is all messed up. My light flashes what seems to be a code with longer pauses and different blink speeds, but it is repeating a pattern. Ohh and that is when my key is in the ignition, when the key is out of the ignition it stays on steady. Going on 6 months now and still nothing from Toyota on how they are going to fix it. Original problem documented at 19,400 miles, now I have almost 24,000 miles and the light is extremely annoying when it is blinking and you are driving at night.....

Anyone have a clue as to what might have caused this. Ohh and it is not disabled cause the "dumb" keys won't start the truck, just the "smart" keys so it is still functioning...and it won't always communicate with Toyota's diagnostic computer either.... I think I just need a new immobilizer brain, but that is alot of cash and toyota is stalling to write that up as warranty, I am about down with the waiting though.... anyone have any ideas on what to do or how to fix or how to get it fixed....
toyomech is offline  
#8 Old 05-22-2008, 04:40 PM
New TN User
 
Join Date: May 2008
Location: NV
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Auto registration

If the imm light flashes a code 22 the system is in auto resgistration and needs three keys programmed to close. Another way to close is five key cycles in ten seconds
toyomech is offline  
#9 Old 05-22-2008, 05:39 PM
Banned
 
Join Date: Dec 2007
Location: Pocatello, Idaho
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
What requires a key cycle. I thought the key needed to be turned for xxx amount of time to "load" data.

Ohh and I just went down to the dealership and they told me that there is no difference between the two black keys and we went out to the truck with scantool and they showed me. They told me to get my wifes key and bring it back tomorrow and we would wipe out the key registration and start over......but now that you mention this 3 key thing, it makes sense because I only have two registered to the vehicle. I am going to go out and turn the key over 5 times fast and see what that does....Thanks I will keep you posted.
mr.trd is offline  
#10 Old 05-22-2008, 05:48 PM
Banned
 
Join Date: Dec 2007
Location: Pocatello, Idaho
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Holy F-bomb!!! It worked. It took me a few tries, cause I tried to (put key in, turn, pull key out) 5 times that didn't do. So then I (put key in, started, pulled key out) 5 times, that didn't work. Then I (put key in, turned on, turned off and left key in) 5 times and sure enough the light is gone!!!! Thank you so much, if you are ever in the Pocatello, Idaho area I owe you a beer or 12 man. I can't wait to get ahold of the dealership and let them know that I won't be bugging them about this again and that it is fixed....Thank You so much the memorial day road trip night driving will be so much nicer now!!!!!
mr.trd is offline  
#11 Old 05-22-2008, 10:59 PM
Official TN Member
 
dbbd1's Avatar
 
Join Date: Oct 2007
Location: Oregon
Posts: 438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 2 reviews
I thought maybe that was how it immobilized the engine, draining the battery, LOL
dbbd1 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Tacoma Forum > 2nd Generation (2005+)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome