defective radio - Toyota Nation Forum : Toyota Car and Truck Forums
2nd Generation (2005+) Discussion area for the 2nd generation of the Toyota Tacoma

 
LinkBack Thread Tools Display Modes
#1 Old 07-09-2009, 07:40 PM
09 Double Taco
 
Skistoy's Avatar
 
Join Date: Jun 2009
Location: Buffalo
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
defective radio

took truck to dealer about defective radio. volume knob stops working, function knob will only allow you adjust 1 number, radio just shuts off. of coarse these problems are intermitant. Everything worked fine for them when i took it in. they could not duplicate any problems. I explained that the problems were intermintant and a known problem ( after reading about them here ). Of coarse they never heard of any problems and could not do anything. they stated there would of been a tsb if there was a problem. so i put my problem to them in another way . I asked if they were telling me i had to live with a defective radio in my new 30k truck. ( i may of been a little more exsplisive ) Demanded to speak with someone else. Luckly the service manager was next to her and heard everything. he reluntantly told her to order a new radio.

Now this week, took truck in to have radio replaced. seeing i was bring it in decided to have auto starter installed also. left truck there all day. picked truck up from the starter girl, works great. asked me if i talked to service dept about the radio. went to service and they now tell me the radio is on 4-6 week back order???? but like they said there is no problems.

Any one else having problems with Northtown Toyota , buffalo NY
Skistoy is offline  
Sponsored Links
Advertisement
 
#2 Old 07-10-2009, 04:47 PM
Official TN Member
 
Join Date: Dec 2006
Location: Arvada, CO
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yes, these radios are on back order, my dealership is currently waiting on 5 units. The problem is with the supplier/manufacturer/remanufacturer (my guess is you have a delphi model AD1808 or AD1807). Sorry you have to wait but have some comfort in knowing you aren't alone. Good luck, deker
dekerman1 is offline  
#3 Old 09-02-2009, 02:56 PM
New TN User
 
Join Date: Sep 2009
Location: maine
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yup, I hear ya. I have a 09 tacoma and on the second radio a AD 1807, which is on back order for another 6 to 8 weeks. When I asked the service people about it all I got was the run around, have to replace it with the same junk that came in it from the factory. I asked them if they want to buy the radio from me give me the money and I'll go put in a better after market one, just think of what one could get for $1300 ? that was the price they sell the same unit for out of thier parts room.
dustman is offline  
#4 Old 09-02-2009, 03:12 PM
Official TN Member
 
Join Date: Aug 2009
Location: patron state of shootin' stuff
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Same problem here. Guess I'm lucky to know the service writer; he just went ahead and ordered me one while I was on the phone with him instead of having me come in. He told me it would be about 5 weeks (2 weeks ago).

For future reference, I've occasionally been able to make the radio turn off by pushing up on the bottom of the housing between the hazard button and HVAC on/off knob. You have to press hard with your thumbs.
BOHICA is offline  
#5 Old 09-02-2009, 07:44 PM
Going to rainforest, BRB
 
HomeGrown's Avatar
 
Join Date: Jul 2006
Location: Georgetown, KY
Posts: 1,545
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 27
Thanked 18 Times in 18 Posts
iTrader Score: 0 reviews
My bigger concern would be with your Toyota dealer, Northtown Toyota. These people can't POSSIBLY not know about the issue with the radios in these trucks, unless your Tacoma is the only '09 they've sold. It should be common knowledge at any Toyota dealer.

2011 Regular Cab, 4x4 Auto, N-Fab step bars, Satoshi grille, OEM fog lights, Extang Trifecta cover (list growing, check back often!)
HomeGrown is offline  
#6 Old 09-02-2009, 08:11 PM
New TN User
 
Join Date: Apr 2009
Location: Morganton,NC
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Hey guys, don't wanna hijack the thread but I have quick question. I too have had my radio replaced. It is functioning normally so far with the exception of the reception. It sucks! I have a 94 Yota pickup with a $100 Walmart radio that picks up much better. I also have a 08 Super Duty that picks up good as well. Anyone else experincing anything like this or have any suggestions for a remedy? Thanks.
09Tarheelyota is offline  
#7 Old 09-02-2009, 08:26 PM
New TN User
 
Join Date: Jan 2009
Location: Alabama
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
i dont have the volume knob issue but i have found that if i turn the radio on from the steering wheel i am unable to turn it off by pushing the power button, i have to use the wheel controls. then last week for some reason while pulling back into the deck at work it just started flashing all kinds of stuff on the display and ejecting discs. of course when i took it in nothing could be found. i really dont want to go aftermarket but i may have to if this gets worse.
Bufit is offline  
#8 Old 09-03-2009, 07:49 PM
Going to rainforest, BRB
 
HomeGrown's Avatar
 
Join Date: Jul 2006
Location: Georgetown, KY
Posts: 1,545
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 27
Thanked 18 Times in 18 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by 09Tarheelyota View Post
Hey guys, don't wanna hijack the thread but I have quick question. I too have had my radio replaced. It is functioning normally so far with the exception of the reception. It sucks! I have a 94 Yota pickup with a $100 Walmart radio that picks up much better. I also have a 08 Super Duty that picks up good as well. Anyone else experincing anything like this or have any suggestions for a remedy? Thanks.

I'd promptly take it back to the dealer and tell them to fix it .... AGAIN. Bad reception = NOT ACCEPTABLE!

2011 Regular Cab, 4x4 Auto, N-Fab step bars, Satoshi grille, OEM fog lights, Extang Trifecta cover (list growing, check back often!)
HomeGrown is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Tacoma Forum > 2nd Generation (2005+)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome