need help: vsc, trac off, check engine light ON - Toyota Nation Forum : Toyota Car and Truck Forums
xB Lounge General discussion area for all generations of the Scion xB.

Reply
 
LinkBack Thread Tools Display Modes
#1 Old 08-26-2005, 02:04 PM
New TN User
 
Join Date: Aug 2005
Location: hawaii
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
need help: vsc, trac off, check engine light ON

hi... My vsc, trac off and check engine light came on again... The mods I did was drop, rims and injen sr intake... I cleaned the maf sensor with electronic cleaner... That did not help...sometimes I smell gasoline by the gas cap... I take out the cap and put it back in... That did not help... then i did the obdII scanner...and got 3 codes...

1. P0441 evaporative emission control system incorrect purge flow

2. P0442 evaporative emission control system leak detected (small leak)

3. P0446 evaporative emission control system vent control circuit malfunction

Not sure what's that... But if anyone know please help... Thanks
chexmixb is offline  
Sponsored Links
Advertisement
 
#2 Old 08-27-2005, 12:28 PM
Old Fart
 
Join Date: Aug 2005
Location: Rockton, IL
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
The last time I had those codes with a Toyota, it was my fault.. I filled the fuel tank, and then topped off a couple times.. Then I parked the vehicle in the hot sun for a couple days after only driving a couple miles.

What happened was the fuel expanded into the charcoal canister and filled it.. Auto Zone checked the codes and reset it for me, and lucky for me, the guy who checked it had seen it before and told me to quit trying to pump gas in after the nozzle clicks..

That was 2 years ago and I've never had a problem, since. I also quit trying to force more gas in the tank..

My guess is, you're still under warranty?? Why not let the dealer take a look?

Waitin' for my box..
Paper is offline  
#3 Old 08-27-2005, 01:07 PM
Reppin my Home
 
troy's Avatar
 
Join Date: Mar 2004
Location: Michigan, USA
Posts: 343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Just so you know, the trac off and VSC light are sensors that are tied into the CEL light sensor, they generally go off when the CEL light goes off.

troy is offline  
#4 Old 10-09-2005, 11:06 PM
New TN User
 
Join Date: Oct 2005
Location: Bellevue NE
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I've been struggling with this same issue. In fact, my 02 Sequoia stalled three times today. I found this site - http://www.findarticles.com/p/articles/mi_qa3828/is_200207/ai_n9092642 - added brake fluid to the master cylinder and problem is gone... Go figure!!!
ybike2 is offline  
#5 Old 10-24-2005, 10:01 PM
Official TN Member
 
Dacatz's Avatar
 
Join Date: Oct 2001
Location: Markham
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 1 reviews
did u get this engine code after u fuel up the tank? if it is, try lock up the gas cap (with min. 3clicks after u tight the cap) and reset the code and it should be fine..... basically this engine code is emission issue....i know for the 98 to 2002 corolla and camry v6 they have a solenoid called VSV or tank VSV near the charcoal cansister always malfunction....try it first see if the gas cap tight first, otherwise u have to send your car back to the dealer to check if the vsv solenoid is okie or not....

ybike2: for your truck is different....since u have low brake fluid, which cause less fluid pressure to control your truck VSC system also your truck have EBD electronic brake thing...that's why it cause it stall....and cel light on.....one more thing, u truck have a special way to bleed the brake.....in which u have to go back to the dealer to do it....becoz of the VSC system....if u don't bring it back to dealer to do it, u might get the cel light again!

Current
92 Previa rwd (Captain seat, dual roof, cool box)95 Previa s/c rwd (Captain seat, dual roof)
Sold
93 Previa rwd Captain seat (parents took it),92 Previa (base model),92 Previa rwd (Captain seat, dual roof),91 Previa rwd (rip),98 240sx rwd,91 Corolla wagon fwd,86 Ae86 rwd
Dacatz is offline  
#6 Old 11-06-2005, 12:39 AM
Toyota bB "Tribute"
 
jethro b's Avatar
 
Join Date: Nov 2005
Location: West,Tn
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Filling the fuel past the click is a big NO NO on the xB. Hopfully they will fix it under warranty. It is an expensive fix if not. Good Luck Bro!

05' Scion xB Classic in BCP Scikotics/Nashville Chapter
If You Don't Drive a Box... Why Bother?
xB= toaster or box
xB2= neither
jethro b is offline  
#7 Old 01-14-2006, 07:01 PM
New TN User
 
Join Date: Jan 2006
Location: Detroit, MI.
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
What up Jethro?!?!?!

funny find you every where...lol
Undrstm8ed is offline  
#8 Old 02-09-2006, 06:30 PM
New TN User
 
Join Date: Jun 2005
Location: North Carolina
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Didn't tighten up my gas tank cap all the way and my did the same thing. Reset at the dealer and its good.
rtrimyer is offline  
#9 Old 02-09-2006, 07:32 PM
Official TN Member
 
Nad1370's Avatar
 
Join Date: Nov 2005
Location: Mid West
Posts: 342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Your under warranty.
Go to the dealer instead of trying to fix it yourself.
Nad1370 is offline  
#10 Old 04-02-2006, 09:11 AM
New TN User
 
Join Date: Apr 2006
Location: Garland, TX
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I just had the same symptom, but it is the symptom of many different problems it seems. They had to replace several parts related to my timing to fix it up. I had to take it in 3 times before it was completely fixed.
trevor.pcgeek@g is offline  
#11 Old 04-03-2006, 02:52 PM
New TN User
 
Join Date: Mar 2006
Location: Irvine
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I had the same problem when I installed my intake, I disconnected my battery for about 15 and let everything reset.
imemikey is offline  
#12 Old 02-20-2009, 11:24 PM
Joined the dark side. :D
 
workerant's Avatar
 
Join Date: Jul 2007
Location: earth
Posts: 5,142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 1,927
Thanked 304 Times in 264 Posts
iTrader Score: 1 reviews
After using the car for over 50K miles and this problem starting to appear. I'll try these easy solutions see if it works. Thanks guys.

Else dealer for me.
workerant is offline  
#13 Old 05-04-2010, 11:45 AM
New TN User
 
Join Date: May 2010
Location: New Jersey
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by chexmixb View Post
hi... My vsc, trac off and check engine light came on again... The mods I did was drop, rims and injen sr intake... I cleaned the maf sensor with electronic cleaner... That did not help...sometimes I smell gasoline by the gas cap... I take out the cap and put it back in... That did not help... then i did the obdII scanner...and got 3 codes...

1. P0441 evaporative emission control system incorrect purge flow

2. P0442 evaporative emission control system leak detected (small leak)

3. P0446 evaporative emission control system vent control circuit malfunction

Not sure what's that... But if anyone know please help... Thanks
I just had this same problem this morning driving to work. Same codes pulled at Autozone. Just wondering if anyone has any more updated information.

Autozone seems to think its a faulty gas cap. Any thoughts?

Thanks in advance,
Fred
Fred_2726 is offline  
#14 Old 02-19-2011, 01:21 PM
New TN User
 
Join Date: Feb 2011
Location: NYC
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Warranty for VSC

Quote:
Originally Posted by Nad1370 View Post
Your under warranty.
Go to the dealer instead of trying to fix it yourself.
My camry has 90k + and 9 years old. When does the warranty for correcting VSC/ Trac Off expire?
Thanks
Pete
PeteNuclear is offline  
#15 Old 02-21-2011, 01:39 PM
Let me out of my cage....
 
HATEnFATE's Avatar
 
Join Date: Jan 2006
Location: My Cage......
Posts: 1,728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 95
Thanked 74 Times in 65 Posts
iTrader Score: 0 reviews
^^
A while back for your car my friend. at BEST..5yrs 60k miles.

"Fools", said I, "You do not know, silence like a cancer grows.
Hear my words that I might teach you. Take my arms that I might reach you"
But my words, like silent raindrops fell, and echoed, in the wells of silence.....

Jason Johnston
Toyota/Scion of Des Moines
(800)342-7045
HATEnFATE is offline  
The Following User Says Thank You to HATEnFATE For This Useful Post:
PeteNuclear (02-10-2013)
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Division and International Models Forums > Scion Forum > xB Forum > xB Lounge

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome