2000 4Runner - Check Engine Light - Toyota Nation Forum : Toyota Car and Truck Forums


» Auto Insurance
» Featured Product
Advertisement
Wheel & Tire Center

Go Back   Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner Lounge

4Runner Lounge General discussion area for all generations of the Toyota 4Runner.

ToyotaNation.com is the premier Toyota Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-09-2006, 08:11 AM   #1 (permalink)
Chuck Norris rules
 
decoy562's Avatar
 
Join Date: Dec 2005
Location: Acworth, GA
Posts: 344
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View decoy562's Photo Gallery
2000 4Runner - Check Engine Light

Hey guys,

My wife has a 2000 4Runner with the 3.4 V6 and 91k miles. Anyways, I replaced the radiator and put in a new battery a couple of days ago. The car then felt sluggish when taking off from a stop sign. After driving it a couple of days, it got much better, but today on the way in to work, the check engine light came on. I check all the fluids regularly, what else could it be? Is there a way to reset the engine light, or just have to take it to the dealer?

TIA
__________________
2006 Tacoma Double Cab - Indigo Ink Pearl, TRD Sport, Tow
2000 4Runner - Black, SR5, wife's car
decoy562 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2006, 07:18 AM   #2 (permalink)
New TN User
 
Join Date: Nov 2005
Location: Central NY
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View jacksonpt's Photo Gallery
There are a million different reasons why the check engine light could be on... anything from the gas cap not being on tight to an O2 sensor going bad to lots of other things.

You'll need to hook up a code reader to find out exactly why it's on, then go from there.
__________________
Jackson
1996 4Runner
5" lift, 33" MTs, bumper, sliders... more to come

~ www.TrailAddict.com ~
jacksonpt is offline   Reply With Quote
Old 01-16-2006, 09:22 AM   #3 (permalink)
New TN User
 
Join Date: Jan 2006
Location: TEXAS
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View yodachic's Photo Gallery
I have a 2000 4runner with 95K and the same thing happened to me. The first time the check engine light came on, which was about 2 weeks ago, it was on for a short period of time and then it came on again on Friday, 1/13/06 and stayed on. My husband took it to Autozone this morning and they did a diagnostic and it came up with the Error Code of P0120, which is "Throttle/Petal Position Sensor/Switch A Circuit Malfunction" So, he is going to go by the Toyota dealership in town and just double check to see if that's what it is and then replace it. The part is approx. $80 at AutoZone.

Hope this helps. I had the same symptoms as your wife need as far as before the light came on. A little sluggish, etc.

Yodachic
yodachic is offline   Reply With Quote
Old 01-16-2006, 11:33 AM   #4 (permalink)
Chuck Norris rules
 
decoy562's Avatar
 
Join Date: Dec 2005
Location: Acworth, GA
Posts: 344
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View decoy562's Photo Gallery
Thanks for the help! I took it to autozone, and the code was P0171 (running too lean with the A/F mixture). I looked it up on this great site, then I replaced the air filter, PCV valve, and clean the MAF sensor. Good as new!
__________________
2006 Tacoma Double Cab - Indigo Ink Pearl, TRD Sport, Tow
2000 4Runner - Black, SR5, wife's car
decoy562 is offline   Reply With Quote
Old 12-18-2006, 05:03 PM   #5 (permalink)
New TN User
 
Join Date: Dec 2006
Location: toronto
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View fittipauli's Photo Gallery
Wink p0171

spray electrical contact cleaner on MAF sensor, reset cpu and your done.
fittipauli is offline   Reply With Quote
Old 11-25-2008, 09:00 AM   #6 (permalink)
New TN User
 
Join Date: Nov 2008
Location: vancouver
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View hhhgame's Photo Gallery
I saw your article in this forum though it's a few years back already I just wanted to ask if changing the trotle position sensor (po120) did the job for the check engine light showing up... I am experiencing the same situation and the diagnostics shows the same po120... thank you
hhhgame is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner Lounge

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Locking gas cap and check engine light on Tacos paco 2nd Generation (2005+) 36 06-06-2008 10:00 PM
1990 Camry Check Engine Light Kep Hardcore Tech and Competition 4 05-20-2006 01:15 PM
Rav4 Check Engine Light but no DTC RNeil RAV4 Forum 8 12-29-2005 06:15 AM
Check Engine Light Jal4950 Archived Corolla threads 12 09-11-2004 11:32 AM
Check Engine Light on 98 corolla 240meowth Archived Corolla threads 0 07-24-2004 05:55 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:17 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
ToyotaNation.com is an independent Toyota/Lexus enthusiast website. ToyotaNation.com is not sponsored by or in any way affiliated with Toyota Motor Sales, USA, Inc. The Toyota, Lexus and Scion names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.