Trouble Code 171 / Where Do I Start Looking? - Toyota Nation Forum : Toyota Car and Truck Forums
4Runner Lounge General discussion area for all generations of the Toyota 4Runner.

 
LinkBack Thread Tools Display Modes
#1 Old 05-03-2006, 01:53 PM
FWP
New TN User
 
Join Date: May 2006
Location: SE PA
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Trouble Code 171 / Where Do I Start Looking?

My check engine light keeps coming on. The only code that keeps coming up is "0171 Bank 1 too lean"

What can cause this code and where do I look for a problem.

Thanks

Frank
FWP is offline  
Sponsored Links
Advertisement
 
#2 Old 07-13-2006, 04:22 PM
New TN User
 
Join Date: Jul 2006
Location: Louisiana
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Same problem...

I'm having the same problem and my local mechanic tried several different tests to try and find the problem, but with no luck. After he had my car for 3 weeks, he finally returned it with no fix.

In my case, it's a 4-Runner. It cranks fine, but the acceleration is horrible. Doesn't matter if it is between 10-20 or 70-80, it's very slow.

I'll keep checking back to see if anyone responded.
grizparker is offline  
#3 Old 07-16-2006, 05:18 PM
00 4Runner 4x4, 06 Prius
 
dandeman's Avatar
 
Join Date: May 2006
Location: Chapel Hill, NC
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 7 Times in 6 Posts
iTrader Score: 0 reviews
You need to clean the Mass Air Flow Sensor as discussed here... http://www.4x4wire.com/toyota/4Runner/tech/OBDII_ECU/

As it becomes contaminated, it tends to under report the volume of air coming into the engine requiring the ECU to correct excessively to avoid running lean...

This link http://www.4x4wire.com/toyota/mainte...tenancep5.html goes directly to a procedure for cleaning the MAF, which ought to be done about every 30,000 miles..

Last edited by dandeman; 07-16-2006 at 05:21 PM.
dandeman is online now  
#4 Old 07-19-2006, 10:34 AM
New TN User
 
Join Date: Jul 2006
Location: Louisiana
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Thanks for the reply...I'll give it a shot.
grizparker is offline  
#5 Old 07-27-2006, 09:27 PM
New TN User
 
Join Date: Jan 2006
Location: Columbus,Ga
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
We took ours to the dealer a year ago and they replaced the mass air flow sensor and it was fixed. Expensive yes, but it shut the wife up even though I told her her that's what it was and I could order a replacement from dallas toyota and do it myself for less. Oh well...$260 for it but it only took them 45 minutes. Mine would have never gone to the dealer (tacoma). I got a great dealer here, you can go in there and ask them and they will tell you what the most likely thing that is causing the code. Her 4runner was a 99 with the 3.4 v-6. Cleaning may work also. The gas mileage went to hell when that code came up too.

Murph
medic2230 is offline  
#6 Old 08-10-2006, 09:05 PM
New TN User
 
Join Date: Jul 2006
Location: San Diego CA
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by FWP
My check engine light keeps coming on. The only code that keeps coming up is "0171 Bank 1 too lean"

What can cause this code and where do I look for a problem.

Thanks

Frank
The code means a lean air/fuel mixture has been indicated by an abnormally rich correction factor.
Chris
shipfitter88 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner Lounge

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome