92 toy pickup high speed bucking with powerloss - Toyota Nation Forum : Toyota Car and Truck Forums

89-95 Toyota Pickup/Hilux Discussion forum for the 89-95 Toyota Pickup/Hilux owners.

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-17-2017, 08:46 PM Thread Starter
New TN User
 
Join Date: Mar 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Unhappy 92 toy pickup high speed bucking with powerloss

got a 92 Toyota 5sp 22RE. at my end and some what of a mechanic. I have replaced distributor, coil, ecm, and ignitor. checked wire continuity from ignitor to ecm. when i drove truck for 5 miles under 55mph no troubles (was not easy on it) then rode it at 80mph for about a mile. then started bucking with CEL flashing. pulled codes 12 and 14. i have checked fuel pressure regulator. fuel pump 1 year old. looking for any help. have read in the forums and not found anything that matches what i am have problems with. idles fine no hesitation in take off.
edsfastfury is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-18-2017, 10:11 AM
Soylent Green sales
 
fourwd1's Avatar
 
Join Date: Jul 2006
Location: the Socialist State of Maryland
Posts: 10,985
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Thanks: 30
Thanked 690 Times in 637 Posts
Lifetime Supreme Member
iTrader Score: 1 reviews
Bucking while accelerating can be caused by a clogged fuel filter, you may want to replace it.
Have you looked into solving the 12 and 14 error codes?

_No THANKs necessary !
84 4Runner rockcrawler - ARBed 5.29's, 36" TSLs, dual t-cases w/4.7 crawler gear, Chevys, 30 spline Marlins
83 p/u trail rig - Buick 231 V6, Weiand intake, Holley 4 bbl, TH-350 auto w/700R4 low gearset, dual tanks ...
89 4Runner - stock
http://www.cardomain.com/id/fourwd1
fourwd1 is offline  
post #3 of 9 Old 03-18-2017, 10:36 AM Thread Starter
New TN User
 
Join Date: Mar 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
i am trying to repair codes. the bucking does it at a steady speed not when you are accelerating
edsfastfury is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 03-18-2017, 10:56 AM
Soylent Green sales
 
fourwd1's Avatar
 
Join Date: Jul 2006
Location: the Socialist State of Maryland
Posts: 10,985
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Thanks: 30
Thanked 690 Times in 637 Posts
Lifetime Supreme Member
iTrader Score: 1 reviews
Does it stop when you let off of the gas pedal?

_No THANKs necessary !
84 4Runner rockcrawler - ARBed 5.29's, 36" TSLs, dual t-cases w/4.7 crawler gear, Chevys, 30 spline Marlins
83 p/u trail rig - Buick 231 V6, Weiand intake, Holley 4 bbl, TH-350 auto w/700R4 low gearset, dual tanks ...
89 4Runner - stock
http://www.cardomain.com/id/fourwd1
fourwd1 is offline  
post #5 of 9 Old 03-18-2017, 03:52 PM Thread Starter
New TN User
 
Join Date: Mar 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
at first it would not. I have replaced fuel filter took it for a drive between 70-80mph after about 17 miles it bucked and shut off with me just gave me code 14 when I got back home. so I have ordered a new ignition control mod. thinking it is breaking down from heat and losing signal. just put one on last week but the code never went away. I have checked wires to ecm they all showed good.
edsfastfury is offline  
post #6 of 9 Old 03-20-2017, 02:15 PM
Soylent Green sales
 
fourwd1's Avatar
 
Join Date: Jul 2006
Location: the Socialist State of Maryland
Posts: 10,985
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Thanks: 30
Thanked 690 Times in 637 Posts
Lifetime Supreme Member
iTrader Score: 1 reviews
Yeah, could be that.
May be worth replacing the coil as well.

_No THANKs necessary !
84 4Runner rockcrawler - ARBed 5.29's, 36" TSLs, dual t-cases w/4.7 crawler gear, Chevys, 30 spline Marlins
83 p/u trail rig - Buick 231 V6, Weiand intake, Holley 4 bbl, TH-350 auto w/700R4 low gearset, dual tanks ...
89 4Runner - stock
http://www.cardomain.com/id/fourwd1
fourwd1 is offline  
post #7 of 9 Old 03-21-2017, 09:45 PM Thread Starter
New TN User
 
Join Date: Mar 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
installed my second ICM. ran just as bad. cleaned out the cat converter and reinstalled. ran better but still bucked and shut off on me. don't seem to like to rev past 3000 rpm. going to remove the bed and check the fuel tank for trash/water. the coil is only 1 week old.
edsfastfury is offline  
post #8 of 9 Old 03-23-2017, 09:10 PM Thread Starter
New TN User
 
Join Date: Mar 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
ok here we go. checked fuel pressure it was a okay. so I figured I would replace the worn out timing chain and who would have known that fixed my problem. who would have thunk that.
edsfastfury is offline  
post #9 of 9 Old 03-24-2017, 07:44 AM
Soylent Green sales
 
fourwd1's Avatar
 
Join Date: Jul 2006
Location: the Socialist State of Maryland
Posts: 10,985
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Thanks: 30
Thanked 690 Times in 637 Posts
Lifetime Supreme Member
iTrader Score: 1 reviews
Wow.
Had it jumped a tooth?

_No THANKs necessary !
84 4Runner rockcrawler - ARBed 5.29's, 36" TSLs, dual t-cases w/4.7 crawler gear, Chevys, 30 spline Marlins
83 p/u trail rig - Buick 231 V6, Weiand intake, Holley 4 bbl, TH-350 auto w/700R4 low gearset, dual tanks ...
89 4Runner - stock
http://www.cardomain.com/id/fourwd1
fourwd1 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Hilux (Pickup) Forum > 89-95 Toyota Pickup/Hilux

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Back