FAQ - Timing Chain, Engine Codes, Surging Idle, Steering Noises, ECT... - Page 5 - Toyota Nation Forum : Toyota Car and Truck Forums

89-95 Toyota Pickup/Hilux Discussion forum for the 89-95 Toyota Pickup/Hilux owners.

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #61 of 64 Old 03-08-2015, 11:36 PM
New TN User
 
Join Date: Mar 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
iTrader Score: 0 reviews
my 89 toy p/u when its cold out, 60 deg or below, below 40 deg, idle surge when I hit the brakes, let off brakes, goes to high idle, let it sit 10 mins, idles great, touch brakes and it does it again.
TK-yota is offline  
Sponsored Links
Advertisement
 
post #62 of 64 Old 03-27-2015, 11:32 AM
New TN User
 
Join Date: Mar 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
iTrader Score: 0 reviews
Alright guys need some help, got 92, 3.0 v6 new coil, fuel pump everything seems to be operating correctly, I can crank the truck, while cold it runs great, but after the motor gets warm or runs a while, whether idling or goin down the rd, it just cuts off and a couple fuses in the box in the cab on driver side are pretty warm, the truck had been under water and up above that box, is there a good chance the fuse box is no good any more and it's just Heating up due to corrosion ?
BigHoss89 is offline  
post #63 of 64 Old 04-11-2015, 09:05 AM
New TN User
 
Join Date: Apr 2015
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
iTrader Score: 0 reviews
Hey guys,

I've just replaced my timing chain and guides, and everything that goes with it. One of the main goals was also to fix a slight oil leak right up the top of the timing case just above the water pump. Now, while the case was off, I made sure the section of head gasket that is free'd up was stuck to the head with gasket goo, then while I placed the timing case back on there was nothing that could possibly get through.
Left it for a few days to dry before getting everything back on and putting oil etc back in. Started her up, did the timing, and sure enough, the little son of a bitch of an oil leak is back in the same spot. Does anyone else have this problem with the 22r???? How do I fix it :/
tracks94 is offline  
Sponsored Links
Advertisement
 
post #64 of 64 Old 06-05-2015, 03:44 PM
Official TN Member
 
Join Date: May 2013
Location: Tustin
Posts: 55
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
iTrader Score: 0 reviews
I have a problem right now where engine timing is low and needs to be forwarded. Idle is low when not giving gas. But as mechanic turned the idle screw up half a turn, didn't fix the problem. Going to have him forward the engine timing. Problem started as he changed the engine timing to pass smog test.
gmantypk is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Hilux (Pickup) Forum > 89-95 Toyota Pickup/Hilux

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
Back