94 pickup 3vze code 25 problem - Toyota Nation Forum : Toyota Car and Truck Forums
89-95 Toyota Pickup/Hilux Discussion forum for the 89-95 Toyota Pickup/Hilux owners. NEW!

 
LinkBack Thread Tools Display Modes
#1 Old 11-04-2009, 09:53 PM
New TN User
 
Join Date: May 2008
Location: Minnesota
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
94 pickup 3vze code 25 problem

I have strange deal with this truck. I bought it and it had zero compression on #3. I was also getting code 25 when this was happening. I didn't have time right away to check it out so I pulled the plenum up enough to unplug the #3 injector so I wouldn't keep dumping fuel into that cylinder. I than cleared the codes since I had disconnected the battery and I never got the code 25 back after I did this. Than last night I pulled the plenum and valve cover and checked valve clearance and the intake valve on #3 was extremely tight. Put a .030 thinner shim in and it is still tight but compression is up to 150psi. I than reconnected the injector and put it all back together. Ran great for a day and now code 25 came back. What is going on here? Would it be a pretty good sign that this injector is not working properly?
enasnitsi is offline  
Sponsored Links
Advertisement
 
#2 Old 11-05-2009, 09:40 PM
YOTA Master
 
Vicoor's Avatar
 
Join Date: Sep 2006
Location: Manassas, VA
Posts: 2,375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 85 Times in 81 Posts
iTrader Score: 0 reviews
did you check the clearances on all the valves?

code 25, Lean condition, is caused when there is excess oxygen in the exhaust stream and the ecm is unable to correct it, if everything else is OK this means it is lean, but if there is anything wrong that would cause excess oxygen, like exhaust leak or misfire this will also cause this code. really, disconnecting an injector should cause a code25 not fix it.

Proper sequence of diagnosis starts with mechanical, then ignition, then fuel system.

Misfires can be caused by mechanical things like incorrect valve clearances, valves not seating properly, valve timing, etc...

or ignition problems, plugs wires, cap , rotor, or timing.

if you get around to the fuel system, oxygen sensor with low output, low fuel pressure air leaks, poor injector spray patterns, or even if it is running so rich as to cause a misfire.


I'd start out making sure all the valve clearances are correct, check compression on all cylinders then if that is all OK proceed to the ignition system.

Don't talk about it, Just do it!

Vicoor is offline  
#3 Old 11-05-2009, 09:51 PM
New TN User
 
Join Date: May 2008
Location: Minnesota
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
I checked all the ones on the right side when I had that pulled off. I just didn't pull the cover off the left side. Compression is around 170 on all cylinders so mechanically it is in pretty good shape I think for 200k miles on it. I'm going to pull the egr valve off and clean that and set the tps tomorrow. It will only set the code when driving about 45mph at about 2000 rpm under light throttle. Than it will start jerking and the light will come on.
enasnitsi is offline  
#4 Old 11-07-2009, 10:00 AM
New TN User
 
Join Date: May 2008
Location: Minnesota
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
The EGR wasn't that dirty so I didn't do much to it. I did disconnect the vacuum hose that goes to the top of the egr and plugged the line. I went and drove it like that and it doesn't jerk anymore and it won't set the check engine light. Not sure if the EGR is bad or if something else is and it just shows up when the EGR is working.
enasnitsi is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Hilux (Pickup) Forum > 89-95 Toyota Pickup/Hilux

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome