P0440 P0441 P0446 - Toyota Nation Forum : Toyota Car and Truck Forums
1st Generation (2001-2007) Forum dedicated to the discussion of 1st generation Toyota Highlanders.

 
LinkBack Thread Tools Display Modes
#1 Old 03-10-2007, 08:05 PM
New TN User
 
Join Date: Mar 2007
Location: Irvine, CA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
P0440 P0441 P0446

These codes came up on my 2002 Highlander - 67k. Checked the fuel cap but looks ok. How long will light stay on if the fuel cap just needed to be tightened?

Thanks all.
Bombbeezee is offline  
Sponsored Links
Advertisement
 
#2 Old 03-11-2007, 08:41 AM
New TN User
 
Join Date: Mar 2007
Location: Virginia
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
codes

Please read my post below under Warranty recall-ECM. I experienced those same codes at 68,000 on my 02 Hlander. I had Autozone check them out and I kept resetting them. They would stay off for varying lengths of time and then come back on. I went in for the latest recall related to 0420 and 0430 and when the ECM reprogramming was done, these codes went off and I got two oxygen sensor codes 0161 and 0141. I have an appointment with the service dept. on Tuesday. They want me to pay for Oxygen sensor replacement but I believe all of this is related and I don't think I should have to pay. I hope this helps.
02fwdHlander is offline  
#3 Old 03-11-2007, 03:45 PM
New TN User
 
Join Date: Mar 2007
Location: Irvine, CA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Talking Im not sure that is related to my problem

I too recently took my car in for the recall. I dont think our two problems are related though, at least mine isnt 02 related.

I did have to fix one of my 02's at about 60k. I think it is a common problem with the Highlander.

After driving for about 40 miles yesterday I checked the fuel cap and when i unscrewed it it didnt give the usual suction noise. I dont know if this is long to build up pressure but I think im going to get a new cap today and see if it helps.

Otherwise i guess i better take it to the dealer and let them tell me how there is a mythical creature poking holes in my exhaust.

Thanks
Bombbeezee is offline  
#4 Old 03-13-2007, 03:20 AM
TN Post Wh*re
 
Join Date: Jun 2006
Location: PNW
Posts: 6,403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 13 Times in 12 Posts
iTrader Score: 0 reviews
There might be a TSB on this issue.
toyomoho is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Highlander Forum > 1st Generation (2001-2007)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome