1999 Rav4 idle problem! please help - Toyota Nation Forum : Toyota Car and Truck Forums


» Auto Insurance
» Featured Product
Advertisement
Wheel & Tire Center

Go Back   Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > RAV4 Forum

RAV4 Forum Looking for RAV4 information and resources? This forum is the place.

ToyotaNation.com is the premier Toyota Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-24-2010, 03:35 PM   #1 (permalink)
New TN User
 
Join Date: May 2010
Location: Houston, TX
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View k3v1n2010's Photo Gallery
1999 Rav4 idle problem! please help

I live in Texas so its warm and when I first start my car and often times anytime I'm at a stop my car idles really ruff. My car has 123,000 miles on it, I have just recently replaced oil, spark plugs and wires, fuel filter, air filter, cleaned the throttle body, and seafoamed my car. This problem has been going on for over a year but it seems to me to getting a little worse. I am not super great with cars but really try taking care of mine.

When I first turn on it idles real low around anywhere to 400-700. It shakes my car real bad. Sometimes it does this weird thing where it vibrates real hard then clicks, and then starts idling real hard again over and over again. This last winter even though not really cold my car did just shut off on me a few times after first pulling out of the driveway. Sometime when I lightly rev up the engine after first turning it on the idle will stay higher around 1000 rpms and then the vibrating goes away but it doesnt always work.

I read that it could be the IAC but would like to find out more about that before I buy the new sensor. I did try cleaning it but it just took an air duster to it and wiped it off with a cloth no real cleaning with like any cleaners or anything.

Please help me out it would really be nice to have a nice idling car again and not feel like I'm going to end up with shaken baby syndrome haha.

Thank you,

Kevin
k3v1n2010 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-28-2010, 04:17 PM   #2 (permalink)
Official TN Member
 
Join Date: Sep 2008
Location: mt airy north carolina
Posts: 156
Gameroom cash: $100200
Thanks: 0
Thanked 10 Times in 10 Posts
iTrader Score: 0 reviews
View hd72m's Photo Gallery
Have someone keep it running and unplug and plug in the connectors for the IAC while spraying throttle body cleaner in IAC.
When you do this it opens and closes IAC and hopefully clean it.
If not take it off and clean it and connections good, also look real good for vacumn leaks.
hd72m is offline   Reply With Quote
Old 05-28-2010, 04:28 PM   #3 (permalink)
Official TN Member
 
Join Date: Sep 2008
Location: mt airy north carolina
Posts: 156
Gameroom cash: $100200
Thanks: 0
Thanked 10 Times in 10 Posts
iTrader Score: 0 reviews
View hd72m's Photo Gallery
This is how to do it
http://rav4world.com/forums/viewtopic.php?t=11555
hd72m is offline   Reply With Quote
Old 05-28-2010, 05:45 PM   #4 (permalink)
New TN User
 
Join Date: May 2010
Location: Australia
Posts: 37
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
View OzRav's Photo Gallery
Here in Australia a new IAC is about $600!

I had a problem with mine sticking. I was advised to clean it with spray carby cleaner which I did and it fixed the problem.

What I did...Remove the air filter complete with the pipes etc. Remove the IAC coil which is the light grey thing just under the air intake on the inlet manifold. You then see a small round magnet. This magnet turns so do not pull or push it. Spray with the cleaner then try turning with your fingers do not use pliers or anything that might damage the magnet. Repeat until the magnet moves freely.

If the problem continues after checking the IAC then it needs to be fixed by Toyota. The control for the IAC is factory set and can only be re-set by Toyota.

Hope that is of help
OzRav is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > RAV4 Forum

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:55 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
ToyotaNation.com is an independent Toyota/Lexus enthusiast website. ToyotaNation.com is not sponsored by or in any way affiliated with Toyota Motor Sales, USA, Inc. The Toyota, Lexus and Scion names and logos are trademarks owned by Toyota Motor Sales, USA, Inc.