Van starts then dies - Toyota Nation Forum : Toyota Car and Truck Forums
Previa Forum Discussion area for the (discontinued) Toyota Previa.

 
LinkBack Thread Tools Display Modes
#1 Old 01-18-2007, 10:53 PM
New TN User
 
Join Date: Jan 2007
Location: New York
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Unhappy Van starts then dies

Help Please: I was driving my van (97 previa) last weekend and it just died out, no warning sign what so ever. It will start up again at any time, the problem is that it will not stay on. It does no difference if I step on the gas to try to keep it going, it's like not registering that command.
I replaced the fuel pump because a friend suguested that was the main culprit, but problem is still the same (the gas filter was replaced in mid summer) . It's not staying on long enough to register any trouble codes (I have an OBDII scanner and the repair manual)
I checked the fuse & most of the relays (main relay, EFI relay, fuel pump relay, Operating relay?). I should mention That the spark plugs, cables & cap & rotor are pretty new. I tested the coil, still the same problem. Imagine yourself turning on your car and as soon as it goes on you turn the key off. I can do that all day until the battery is drain.

I apply voltage directly from the fuse panel to the fuel pump connector and I can hear the pump working, immediately I turn the key to start it but it still dies right away. I replace my fuel filter every year and this one has only 3-4 months. This weekend I will replace the fuel filter just to make sure it's not that. Then I will check to see just how much fuel is comming back on the return line. It's been one long week with out my previa, and I am determine to fix it myself and with your advise.

Can anyone please direct me to the component that I might have over look. I Will appreciate greatly any good advise.

Thank you for you time.
Anthony D.
97 Previa LE/SC
her94previa is offline  
Sponsored Links
Advertisement
 
#2 Old 02-11-2007, 10:11 PM
New TN User
 
Join Date: Jan 2007
Location: New York
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Van starts then Dies: Fixed

Problem solved, Thanks for all the help.
her94previa is offline  
#3 Old 02-27-2008, 01:15 PM
New TN User
 
Join Date: Feb 2008
Location: Chicago
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
how did you fix the problem? i'm having the same issues with my 96 le/sc and its driving me nuts! help please!
teeteeracer is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Previa Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome