2.5 to 2.4 swap issue - Toyota Nation Forum : Toyota Car and Truck Forums
Hardcore Tech and Competition Strictly HARDCORE tech info and questions and also autocross / racing discussion!

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-05-2017, 04:33 PM Thread Starter
New TN User
 
Join Date: Sep 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
2.5 to 2.4 swap issue

Hey guys.. New here. Have a little problem I'm hoping you can help with. I have a 09 rolled camry with 26k miles and a 2011 with 255k. I decided to swap all mechanical parts off the 09 to the 11. Suspension and all. Well everything is swapped with zero issues. The 2.4 and trans now lives where the 2.5 was. Everything seemed to bolt right up and plug right in. Only issue I'm having now is the engine will crank but not start. No spark. I'm guessing its a key/immobilizer issue. One other thing I did notice is the check engine light is pretty dim. I plugged the 2.5 way back in just to check the light circuit and it was bright with that ecu. Not sure why that is either.

Any ideas?

Also I'm looking for the procedure to link everything up.. Ecu, key, immobilizer

Thanks in advance
Teckarmy1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-07-2017, 09:17 PM
Senior TN Member
 
Join Date: Jan 2009
Location: S.F. East Bay
Posts: 7,353
Mentioned: 47 Post(s)
Tagged: 0 Thread(s)
Quoted: 1884 Post(s)
Thanks: 109
Thanked 816 Times in 750 Posts
Lifetime Supreme Member
iTrader Score: 0 reviews
Entire 2.4l engine + harness + ECU needs to be swapped together. Can't mix and match parts. Everything must come across.
DannoXYZ is offline  
post #3 of 3 Old 09-07-2017, 09:34 PM Thread Starter
New TN User
 
Join Date: Sep 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
I did that. Engine. Complete harness. Ecu and transmission. I used nothing from the old engine or harness.
Teckarmy1 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Nation Forums > Hardcore Tech and Competition

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome