Water pump replace/low idle - Toyota Nation Forum : Toyota Car and Truck Forums
Tundra 2nd Generation (2007-2013) Discussion of the 2nd generation of the Toyota Tundra

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-30-2018, 07:39 AM Thread Starter
New TN User
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Water pump replace/low idle

I replaced the water pump thermostat and belt on my 07 tundra 5.7L. I started it and she idle properly for the about the 1st 10min, then the idle went down to 5 almost like it wants to turn off. I put the belt on the correct way. Any idea what could be wrong. Help.
MannyP is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-03-2018, 12:19 AM
T100 Road Warrior...
 
BamZipPow's Avatar
 
Join Date: Sep 2006
Location: The Woodlands, TX
Posts: 13,169
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 900 Post(s)
Thanks: 3,542
Thanked 3,691 Times in 2,921 Posts
Supreme Member
Garage
iTrader Score: 0 reviews
Wink

Welcome to the forums!

How clean is yer throttle body? Maybe it's got some build up under the butterfly valve?
https://www.tundratalk.net/forums/tu...-low-idle.html

1998 T-100 SR5 2WD auto, Roadmaster Active suspension, dual oil catch jars, AC mod, aero cap, lower aero package, 67% grill block, aero single wheel trailer
BamZipPow is online now  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Tundra Forum > Tundra 2nd Generation (2007-2013)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome