Toyota Nation Forum : Toyota Car and Truck Forums

Toyota Nation Forum : Toyota Car and Truck Forums (https://www.toyotanation.com/forum/)
-   Corona Forum (https://www.toyotanation.com/forum/128-corona-forum/)
-   -   Corona running on 2 cylinders (https://www.toyotanation.com/forum/128-corona-forum/1506194-corona-running-2-cylinders.html)

Noel Moulton 07-05-2017 06:31 AM

Corona running on 2 cylinders
 
A warm welcome from Down Under.

Hi Folks,


I am a 75 year old car enthusiast from Western Australia. Last year I sold my Simca which I had for 26 years and now find I am suffering withdrawal symptoms in not having an old car. I have now purchased a 1984 Toyota Corona sedan which is in exceptionally good condition except for a seized motor, for which I have obtained a second hand replacement. Before installing this engine I replaced the timing belt, water pump, thermostat and housing plus new spark plugs. Now the engine is in the car we find it is running on only two cylinders 1 & 2. We have checked the compression three times now and we get 150lbs on each of the four cylinders, there is a healthy spark to each cylinder and I have installed a new distributor cap and rotor, I have also replaced the manifold gasket with a new one and it still runs only on two cylinders. What is unusual with the replacement motor is that the air pump supplies the air to the exhaust ports on cylinder 3 & 4, there is no entry cast for 1 & 2, I have plugged the entry into 3 & 4. I suspect there must be a problem with the emission control system which is a nightmare. Can anyone help me solve the problem as a packet of matches seems to be a solution to my frustration.

BMR 07-05-2017 10:20 AM

Welcome to TN Noel!

Which engine is in your Corona?

In my experience, the presence of spark with the plug removed can be a false positive, meaning there might not be spark when the plug is installed and trying to spark inside a cylinder with good compression. I see you've replaced everything but the plug wires?

Carl H 07-05-2017 11:05 AM

I assume it is fuel injected?? Try swapping out injectors. Are the non running cylinders' spark plugs wet from gas ? Are those cylinders getting gas?

Noel Moulton 07-05-2017 08:10 PM

Quote:

Originally Posted by BMR (Post 12641930)
Welcome to TN Noel!

Which engine is in your Corona?

In my experience, the presence of spark with the plug removed can be a false positive, meaning there might not be spark when the plug is installed and trying to spark inside a cylinder with good compression. I see you've replaced everything but the plug wires?

It has the 2S-C carburettor engine. I have swapped the leads across the cylinders and have tried leads from the motor I took out, all without any joy.

fourwd1 07-05-2017 08:47 PM

Maybe the distributor is installed a few teeth off, or the timing belt.

BMR 07-05-2017 09:13 PM

Back to basics. Fuel, spark, compression, and spark timing. Compression readings are good, and hard to doubt. It's carbureted, so it's hard to have only two cyl's run and be a carburetion problem. That leaves spark and spark timing.

Is the distributor good? No bent rotor shaft, or oil leaking into it? Cap is on straight? I once had a misfire develop because the cap was on tilted.

Noel Moulton 07-05-2017 11:21 PM

Corona on 2 cylinders
 
A sincere thank you to each of you guys that have responded with a possible fix, it's really appreciated. Over the weekend I will hone in on the distributor and try to work out if the timing is out. Any other suggestions would be welcome.

Cheers.

Noel

Carl H 07-06-2017 06:50 AM

Are you sure you have the proper wire on the proper cylinder, # 1 from distributor on # 1 cylinder etc. With a carb and manifold , unless something is blocking off a port, you should be getting fuel to all cylinders, so that ends up being spark and timing most likely, 2 spark plug wires on the wrong cylinder??

Noel Moulton 07-06-2017 07:38 PM

Corona on 2 cylinders
 
Thank's Carl. Hard to go wrong with the wires but we did check them all the same, the problem has got us baffled.

The only other car to ever get on top of me was the 1974 Citroen DS which I had about 30 years back, every time I took it out something went wrong but it was the best car I have ever driven.

Carl H 07-07-2017 07:03 AM

One tool I use quite a bit is a strobe timing light, You can use it to set timing on the #1 cylinder, But you can use it to see how it strobes on other cylinders, (to see how steady they get a pulse/ light.)

My strobe light has a clip on connector , so it is easy to go from one to the other cylinder plug wire. One timing light I have has a variable degree knob , so you can check to see if the cylinder is getting the proper advance in degrees at high RPMs by turning the knob.

You can also make your own timing marks for the other 3 cylinders and see if they are getting the proper spark at the right time.

If all this does not work, does the car have the proper electronic control box and the proper distributor in it and does it fire all the cylinders in the correct order and at the right time??


All times are GMT -5. The time now is 02:41 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome