Crazy issue with central locks- 2003 Matrix - Toyota Nation Forum : Toyota Car and Truck Forums
Corolla 9th Gen/1st Gen Matrix (2003-2008) 9th generation Corolla and 1st generation Matrix discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-11-2019, 10:58 AM Thread Starter
New TN User
 
Join Date: Jun 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Crazy issue with central locks- 2003 Matrix

Hello all,
I have a crazy problem with central locks that started happening after I changed my drivers door (because of rust). Since then, I have replaced the new doors harness with my original door harness and now most of the issues have gone away- but still some remain.

1. Power lock/unlock toggle button does not work. Hatch button inside car does not work.
2. Remote button only unlocks driver door. Does not lock any doors.
3. If any door (including hatch) is open, the rear window hatch keeps making a clicking noise- as if trying to open.
4. These issues prevail, even if I completely disconnect all door harnesses from the car.
5. Door fuse is good. All other fuses are also good.

Here are the things I tried:
1. Tried resetting the BCM by disconnecting both battery terminals for more than 30 mins
2. Changed the driver door lock and actuator back to the original
3. Tried to isolate the central locking toggle switch

I'm running out of ideas. Any help would be appreciated.
Ajit Pharne is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-11-2019, 01:28 PM
Moderator
 
75aces's Avatar
 
Join Date: May 2012
Location: Valley of the Sun
Posts: 4,351
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 987 Post(s)
Thanks: 62
Thanked 212 Times in 206 Posts
Lifetime Supreme Member
Garage
iTrader Score: 0 reviews
Was this the case before you replaced the door?

In the garage,

9th Gen Corolla XRS
2012 Mazda 5

"If it ain't broke yet, it's probably still working like a Swiss time piece; until you open it up and all hell breaks loose"
75aces is online now  
post #3 of 4 Old 06-12-2019, 02:19 PM Thread Starter
New TN User
 
Join Date: Jun 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Everything worked perfect before the door was replaced.

Can anyone tell me the location of the Body module on the car and what it takes to replace it?
Ajit Pharne is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-12-2019, 11:11 PM
Moderator
 
75aces's Avatar
 
Join Date: May 2012
Location: Valley of the Sun
Posts: 4,351
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 987 Post(s)
Thanks: 62
Thanked 212 Times in 206 Posts
Lifetime Supreme Member
Garage
iTrader Score: 0 reviews
Double check the connectors and wiring for damage. Not likely, but it's a start.

May have missed something.

In the garage,

9th Gen Corolla XRS
2012 Mazda 5

"If it ain't broke yet, it's probably still working like a Swiss time piece; until you open it up and all hell breaks loose"
75aces is online now  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Corolla and Matrix Forum > Corolla 9th Gen/1st Gen Matrix (2003-2008)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome