2012 Venza slow starting - Toyota Nation Forum : Toyota Car and Truck Forums
Venza Forum Discussion area for the Toyota Venza, a new crossover sedan vehicle. (2009+ model year)

 2Likes
  • 1 Post By 9009RPM
  • 1 Post By Art_Diesel
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 06-15-2019, 10:35 AM Thread Starter
New TN User
 
Join Date: Feb 2014
Location: Vegas
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
2012 Venza slow starting

Hi guys. I have a 2012 Venza XLE V6. The last few months when I go to start the car sometimes(50%) it takes an extra second or two to start. I recently changed the spark plugs(Iridium) and the air filter. I also changed the oil and replaced the pcv valve. I also ran a bottle of regular Chemtool thru the gas. Has anyone had this issue or have any idea what it could be? It's not throwing a code so everything seems to be fine besides that. Thanks in advance


car has 85,000 miles

Last edited by Art_Diesel; 06-15-2019 at 10:45 AM.
Art_Diesel is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 06-15-2019, 10:40 AM
Official TN Member
 
Join Date: Feb 2014
Posts: 130
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 4
Thanked 18 Times in 15 Posts
iTrader Score: 0 reviews
Mileage? Maybe it's the starter

PAST: 2002 Nissan Sentra GXE 5SPD I 2003 Honda S2000 I 2001 Toyota Highlander V6 AWD
CURRENT: 2014 Porsche Cayenne V6 I 2018 Honda Civic Type R

9009RPM is offline  
post #3 of 6 Old 06-15-2019, 10:40 AM Thread Starter
New TN User
 
Join Date: Feb 2014
Location: Vegas
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by 9009RPM View Post
Mileage? Maybe it's the starter



Oh sorry about that- 85,000 miles
Art_Diesel is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 06-15-2019, 11:02 AM
Official TN Member
 
Join Date: Feb 2014
Posts: 130
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Thanks: 4
Thanked 18 Times in 15 Posts
iTrader Score: 0 reviews
How about the battery? I would check it first
lburton likes this.

PAST: 2002 Nissan Sentra GXE 5SPD I 2003 Honda S2000 I 2001 Toyota Highlander V6 AWD
CURRENT: 2014 Porsche Cayenne V6 I 2018 Honda Civic Type R

9009RPM is offline  
post #5 of 6 Old 06-16-2019, 01:09 PM
Green Eyed Monster
 
lburton's Avatar
 
Join Date: Oct 2011
Location: Ohio, North Coast, East Side
Posts: 2,857
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 440 Post(s)
Thanks: 368
Thanked 418 Times in 354 Posts
Supreme Member
Garage
iTrader Score: 0 reviews
Quote:
Originally Posted by 9009RPM View Post
How about the battery? I would check it first



Definitely check the battery, OEM ones are not very reliable.

My Customized Venza

35% Tints/K&N Intake/Tint Head-Tails/Billet Grille/MagnaFlow CatBack/22" Asantis/265-40R22/Megan Coilovers
lburton is offline  
post #6 of 6 Old 06-16-2019, 01:18 PM Thread Starter
New TN User
 
Join Date: Feb 2014
Location: Vegas
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Quote:
Originally Posted by lburton View Post
Definitely check the battery, OEM ones are not very reliable.

I replaced the battery a couple months ago. I recently checked it and it's good. Im going to clean the maf sensor and the throttle body and see how that goes.
lburton likes this.
Art_Diesel is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Venza Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome