New guy with brake light troubles - Toyota Nation Forum : Toyota Car and Truck Forums
Avalon 1st Generation (1995-1999) Specific discussion of the first generation Toyota Avalon

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-03-2018, 06:28 PM Thread Starter
New TN User
 
Join Date: Dec 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
New guy with brake light troubles

Hello everyone, just recently my 96 Toyota Avalon started acting up. My brake light switch went out on a long trip, replaced it and still nothing. I checked the fuses changed the bulbs . I noticed the fuse box was melted on the stop light switch fuse, replaced the fuse box and now the brake light switch works when it feels like.

Anyone else experience this issue??
Carlitos_wey is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-03-2018, 08:43 PM
BMR
Sheriff of Mayberry
 
BMR's Avatar
 
Join Date: Dec 2007
Location: Colorado
Posts: 12,187
Mentioned: 45 Post(s)
Tagged: 0 Thread(s)
Quoted: 1819 Post(s)
Thanks: 532
Thanked 2,200 Times in 1,900 Posts
Lifetime Supreme Member
Garage
iTrader Score: 2 reviews
Hey thereís Carlito, and welcome to the TN forums!

Canít say Iíve experienced that. Sounds like thereís a short to ground somewhere.

2015 RAV4 Limited, AWD, tech pkg, Barcelona red metallic, 62k miles
1996 Avalon XLS, ABS brakes, super white II, acquired w/ 139k, now at 397k
1992 Camry LE, V6 (3VZ-FE), ABS brakes, dark emerald pearl, owned since new. Replaced HGs @332k, totaled at 384k miles
BMR is offline  
post #3 of 3 Old 03-28-2019, 11:23 PM
New TN User
 
Join Date: Jan 2008
Location: CA
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
I realize this is an old-ish thread, but I had an issue about 8 years ago where my brake lights went wonky because of the bulb failure indicator box, which is found in the trunk of the car. I ended up having to bypass this box with some wire splicing, and all has been well since then (but now my instrument cluster doesn't tell me when a light is out anymore).
grap112ler is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Avalon Forum > Avalon 1st Generation (1995-1999)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome