2000 echo rough idle in drive - Toyota Nation Forum : Toyota Car and Truck Forums
Yaris/Scion iA, Vitz and Echo Forum Discussion area for all the Toyota Yaris/Scion iA, Echo, and Vitz owners worldwide.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-07-2019, 11:43 AM Thread Starter
New TN User
 
Join Date: Sep 2010
Location: suffolk county
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
2000 echo rough idle in drive

Hi All echo has a really bad rough idle in drive if i put in park or N idles ok it drives fine plenty power when stoppped at light idle is so rough hear engine vibrating i check purge valve hoses gas cap charcoal cannister n hoses checked mas flow sensor air filter clean all vacum lines plugs coils Thanks for any ideas why idle rough in gear
echo man is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-27-2019, 08:24 PM
Official TN Member
 
Join Date: Aug 2013
Location: The Moon
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Thanks: 15
Thanked 16 Times in 16 Posts
iTrader Score: 0 reviews
Engine Mounts?
l33ch is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Passenger and Sports Car Forums > Yaris/Scion iA, Vitz and Echo Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome