High idle, 4x4 light blinking and no cruze - Toyota Nation Forum : Toyota Car and Truck Forums
4Runner 3rd Generation (1996-2002) Discussion area for the third generation Toyota 4Runner.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-19-2019, 12:35 PM Thread Starter
New TN User
 
Join Date: Mar 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
High idle, 4x4 light blinking and no cruze

Ok I just picked up a 2000 4runner. It currently has a high idle around 1700 rpm. I have changed collant temp sensor and checked all vacume lines. Also have checked throttle body for play. Still no success. Also the 4x4 light is blinking. I've checked front drive shaft and it seems front diff still locked in. Just wanting to know where to start with the 4x4. Also the cruse control don't set. The light comes on in the dash but doesn't actually set.
Schrammbo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-19-2019, 12:59 PM
Official TN Member
 
superj's Avatar
 
Join Date: Nov 2017
Posts: 111
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Thanks: 0
Thanked 10 Times in 10 Posts
Garage
iTrader Score: 0 reviews
I don't know much about 4runners but on other makes/models, there is sometimes a second switch on the brake pedal that goes bad and won't let the cruise activate. also, sometimes its a single switch with two sensors and the cruise part goes bad.


do your tail lights come on when you hit the brakes?

a multicar family. 1 ford escape, 1 Toyota camry, 3 bmw 325 (e30)
superj is offline  
post #3 of 3 Old 03-19-2019, 01:12 PM Thread Starter
New TN User
 
Join Date: Mar 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Yes brake lights work fine. Cruze the the least of my worries though. High idle and 4x4 is the main ones I'm concerned about
Schrammbo is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner 3rd Generation (1996-2002)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome