Tachometer - Toyota Nation Forum : Toyota Car and Truck Forums
4Runner 4th Generation (2003-2009) Discussion area for the fourth generation Toyota 4Runner.

 1Likes
  • 1 Post By rod jr
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-28-2018, 12:20 PM Thread Starter
Official TN Member
 
Join Date: Jul 2009
Location: So Cal.
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Tachometer

On my 2004 4Runner my tachometer stopped working, all other instruments are working good, any ideas on how to fix?
rod jr is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 08-30-2018, 01:04 AM
T100 Road Warrior...
 
BamZipPow's Avatar
 
Join Date: Sep 2006
Location: The Woodlands, TX
Posts: 13,180
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 901 Post(s)
Thanks: 3,542
Thanked 3,691 Times in 2,921 Posts
Supreme Member
Garage
iTrader Score: 0 reviews
Wink

If I remember correctly, the ECU pulls the signal from the ignitor. Check the wiring to the ignitor (might be on the right fender) as well as the ground (especially underneath the ignitor) fer rust or bad contacts.

1998 T-100 SR5 2WD auto, Roadmaster Active suspension, dual oil catch jars, AC mod, aero cap, lower aero package, 67% grill block, aero single wheel trailer
BamZipPow is online now  
post #3 of 8 Old 08-30-2018, 11:07 AM Thread Starter
Official TN Member
 
Join Date: Jul 2009
Location: So Cal.
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
I could not locate ignitor. All other gauges work fine, truck runs good, somewhere I read that the stepper motor for tach might be bad. What are your thoughts on this?
rod jr is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 09-02-2018, 10:57 PM
T100 Road Warrior...
 
BamZipPow's Avatar
 
Join Date: Sep 2006
Location: The Woodlands, TX
Posts: 13,180
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 901 Post(s)
Thanks: 3,542
Thanked 3,691 Times in 2,921 Posts
Supreme Member
Garage
iTrader Score: 0 reviews
Wink

My apologies! Yer year group uses the 4.0L V6, right? Most likely the stepper motor in the tach.

1998 T-100 SR5 2WD auto, Roadmaster Active suspension, dual oil catch jars, AC mod, aero cap, lower aero package, 67% grill block, aero single wheel trailer
BamZipPow is online now  
post #5 of 8 Old 09-03-2018, 10:13 AM Thread Starter
Official TN Member
 
Join Date: Jul 2009
Location: So Cal.
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
I ordered a new stepper motor, hope that fixes problem, will update after install.
rod jr is offline  
post #6 of 8 Old 09-05-2018, 03:03 PM Thread Starter
Official TN Member
 
Join Date: Jul 2009
Location: So Cal.
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Thumbs up

Installed the new stepper motor today, works great !
BamZipPow likes this.
rod jr is offline  
post #7 of 8 Old 09-11-2018, 03:56 AM
T100 Road Warrior...
 
BamZipPow's Avatar
 
Join Date: Sep 2006
Location: The Woodlands, TX
Posts: 13,180
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 901 Post(s)
Thanks: 3,542
Thanked 3,691 Times in 2,921 Posts
Supreme Member
Garage
iTrader Score: 0 reviews
Wink

Congratulations on the fix!

Do you happen to have the part number and where you got it from?

1998 T-100 SR5 2WD auto, Roadmaster Active suspension, dual oil catch jars, AC mod, aero cap, lower aero package, 67% grill block, aero single wheel trailer
BamZipPow is online now  
post #8 of 8 Old 09-11-2018, 09:59 AM Thread Starter
Official TN Member
 
Join Date: Jul 2009
Location: So Cal.
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
rod jr is offline  
The Following User Says Thank You to rod jr For This Useful Post:
BamZipPow (09-11-2018)
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner 4th Generation (2003-2009)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome