sound like a vacuum cleaner - battery light on - Toyota Nation Forum : Toyota Car and Truck Forums
4Runner 4th Generation (2003-2009) Discussion area for the fourth generation Toyota 4Runner.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-17-2019, 04:04 PM Thread Starter
New TN User
 
Join Date: Jun 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
sound like a vacuum cleaner - battery light on

Hi, this morning my battery light came on and a strange sound was coming from the motor - see this video to hear the sound:
Does someone know what it is, thanks!
styve is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-18-2019, 11:11 AM
Senior TN Member
 
Join Date: Apr 2008
Location: Austin, Texas
Posts: 1,539
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 230 Post(s)
Thanks: 0
Thanked 124 Times in 118 Posts
iTrader Score: 0 reviews
Battery light on, whine from engine bay. Uh, Alternator? Take off belt and see if noise stops and spin alternator by hand to see how it feels.
chuckoff is offline  
post #3 of 4 Old 06-18-2019, 02:03 PM Thread Starter
New TN User
 
Join Date: Jun 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Yes, I went to the garage today and it seems that it is the alternator, it doesn't make any noise anymore but the battery light is on and my battery was dead when I arrive at the garage. I'm looking to have it replaced, I will let you know if the problem fixes. Thanks!
styve is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-09-2019, 10:50 AM
New TN User
 
Join Date: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
new alternator

Quote:
Originally Posted by styve View Post
Yes, I went to the garage today and it seems that it is the alternator, it doesn't make any noise anymore but the battery light is on and my battery was dead when I arrive at the garage. I'm looking to have it replaced, I will let you know if the problem fixes. Thanks!

Just returned from local mechanic -- I had read that it might be alternator problems -- and it was. I have a 2007 4-runner and the mechanic told me it was the original alternator, so I reckon I got my money's worth. Flashing lights on my dashboard for almost 2 years -- nobody could pinpoint it. Finally, the battery light came on, so I knew that -- it was serious. Not as bad as I thought. An alternator that old deserves to be replaced.

Now, if I could just get the tire pressure light to go away.
Carol Niswonger is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > 4Runner Forum > 4Runner 4th Generation (2003-2009)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome