Inverter Coolant Pump Failure Diagnosis and Replacement - Toyota Nation Forum : Toyota Car and Truck Forums
Highlander Hybrid The first hybrid SUV from Toyota, the Highlander Hybrid!

 2Likes
  • 1 Post By billbmsn
  • 1 Post By billbmsn
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-25-2018, 05:38 PM Thread Starter
New TN User
 
Join Date: Dec 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Inverter Coolant Pump Failure Diagnosis and Replacement

Iím posting this because after searching high and low I found nothing describing how to diagnose and replace the inverter cooling pump on a Highlander Hybrid. There are a lot of guides for this task on the Prius, but the layout is not the same and the Prius guides do not help with replacement. This electric pump is part of the inverterís dedicated cooling system on all Toyota hybrids. Without it, the inverter will overheat and fail. The inverter is a $7,000+ part.

BACKGROUND: How the problem appeared and was diagnosed.

Last week my trusty 2006 HiHy Limited with 179k miles gave me its first bit of trouble. As I was backing out of the driveway, I saw the warnings "Check VSC" and "Check Hybrid System" and virtually every warning light on the dash lit up. The car seemed to be operating fine, the hybrid battery was charging, but I pulled it back into the garage. I thought, well, it's been 12+ years, so it's about time for the hybrid battery to fail.

I snooped around a bit online and found "Dr. Prius" hybrid diagnostic software (for Android and IOS) that could read the trouble codes and do all kinds of diagnostic on the hybrid battery and its charging system via the OBD2 port. I ordered a Veepeak OBD2 Bluetooth scanner, Dr. Priusís favorite scanner despite being very inexpensive ($11 on Amazon). The Dr. Prius app is free to download. For free it reads and interprets error codes. I saw my system was throwing a P0A05 error code, inverter pump circuit open. I could have stopped there, but I wanted to make sure the battery pack was OK. To do advanced hybrid system diagnostics the app asks for $8.99 to 28.99. It looked like the $8.99 ďlimitedĒ diagnostics would tell me the status of each battery pack cell and test the charging system. I gladly paid it.

Dr. Prius's hybrid system tests showed that all the battery cells were balanced and within voltage range and the system charged perfectly. The charging test required a short drive that I thought should not overheat the inverter despite the pump failure. I could have skipped that test since the battery voltages were fine and I could see the inverter was sending power to the battery just sitting in the garage.

P0A05 could be due to failure of the electronics controlling the pump, wiring issues, or the pump itself. I noticed the pump fuse had blown. I replaced it and it blew as soon as I tried to start the car. That's good evidence of a seized or shorted pump drawing excessive current, although it could be a harness short. The harness looked fine, so I went with the pump itself being the culprit.

Many people report error code P0A93 as well. I could not determine how this differs from P0A05. I got a vague impression that this is a more serious code as it appears that when this is found the car symptoms include abrupt shutdown. My car continued to run and charge well, but driving the car briefly to check the hybrid battery as I did may not be a good idea.

I looked up the pump (found under electrical system, hybrid cooling OR hybrid components, inverter cooling on most Toyota dealer parts sites), finding G9040-48080 for 2006-7. There is some confusion about this part, as some sites show G9030-48020, indicating it is for 06-7 HiHy with the tow package, while G9040-48080 is for a HiHy w/o that package. The tow package inverter pump is over $100 more. We have a tow bar and trailer light socket that look factory installed, but I'm not sure as we are not the original owners. I had already ordered the less expensive pump (discounted well under $200) before seeing this and when it arrived it was absolutely identical to the original pump. To add a bit more confusion, I found another part, G9020-48050 that applies to 2006-7 HiHy too. G9040-48080 is correct for my car when I entered my VIN. NOTE: These part numbers only apply to the 2006-7 HiHy, although I believe everything else in this guide would apply to later model years.


STEPS TO REPLACE THE PUMP:

The pump is located down behind the radiator on the left side of the engine compartment. To see and access it from above,

- Remove the front half of the cover over the left side of the engine. The pump is at the end of the long hose coming from the lower right corner of the photo down to an area near the bottom of the radiator:




- Remove the harness plug from the pump. There is a tab to squeeze in on the forward face of the plug to release it as you pull.



- Jack the car up to gain working space underneath. I chose to use the supplied scissor jack as the I could not easily spot a sturdy enough looking side frame member on my HiHy. The engine subframe looks like it would be a good option for a floor jack.

- Remove the front splash shield from the bottom of the bumper.

After that you can see the pump, but good access is blocked by the bracket that goes from the subframe to the front crossmember. So, I chose to remove that bracket. I positioned a floor jack under the subframe before removing the bracket because a major subframe bolt is removed as part of this process.

- Remove the subframe bracket blocking good access to the pump (One long 19mm bolt, two 14mm bolts and one 14mm nut).

Front of bracket showing 2 of the 3 front fasteners. Photo was taken after the new, shiny pump was installed.



Rear area of bracket showing 19mm head of a LONG (~6 in) bolt.



- Remove the three 10mm nut/washer combos from the bottom side of the pump.

This shows the nuts with one of the three already removed. This is the bad pump. It appears the pump was leaking a bit too. I never saw coolant drops under the car.




This frees the pump from the main bracket. Push the pump up.




- Drain the inverter coolant by removing the 10mm Allen plug from the bottom of the transmission. I tried just clamping the two coolant hoses that go to the pump and not draining the fluid. The hoses were still very pliable but I could not clamp them shut with the hose pinching tools I had. I did not drain the inverter radiator which is a small unit in front of the engine radiator. That process has been described earlier here:

https://www.toyotanation.com/forum/6...t-07-hihy.html

If your coolant has not been changed in 5 years or 60,000 miles, you should drain the entire system. Mine had recently been changed. This looks a bit wet because I snapped the photo after draining the coolant.




- Move the clamp on the lower hose and work that hose off the pump. Expect some additional fluid to splatter. Not a whole lot, but have a container to catch it. (SORRY, NO MORE PICTURES.)

- If your coolant hoses are still very flexible, you can pull the pump up and with a bit of maneuvering get it fully out. It's tight but it should come out. This definitely crimps the upper hose in 2 places, but it did not harm mine. This made removing the hose and attaching it to the new pump a snap. If you can get the upper hose off the pump another way, terrific. There's not much access from below, but that may be worth a try as an alternative.

- Fit the Upper hose to the new pump.

- Work the new pump down into position. Align the bolts on the pump with the mounting bushings on the bracket and reinstall the 10 mm nut/washer combos. The furthermost nut could be a pain to reinstall as there is little hand room. I used a 10mm Gearwrench to hold the nut/washer, move it into place and reinstall it.

- Reattach the lower hose.

- Reattach the harness plug from above. It only fits one way. Remember the tab faces forward.

- Install a new fuse if needed.

- Fill up the coolant reservoir. This takes same pink Toyota/Lexus coolant as the engine cooling system, but Zerex and Valvoline make a perfect equivalent pink coolant that is less than half the price of actual Toyota brand.

- Refill the reservoir a few more times as the level drops over several minutes. You may see air bubbles entering the reservoir.

- Start the car. You may still get a "Check Hybrid System" warning at first. I did, but the "Check VSC" warning was gone. The coolant level will drop quickly. Shut off the car after a minute and refill the coolant. After that I no longer saw ANY error messages on restarting the car!

- Finish up reinstalling the subframe bracket, lower valence, etc.

- Drive the car and recheck the coolant level as air bleeds out of the system over the first few days.

I'm guessing this is probably an $800-$1,000 repair by a qualified repair shop. I understand that Toyota generally charges $300-$400 just to run the diagnostics on the hybrid system. I spent $189 for the pump delivered and $20 for diagnostic software and OBD2 scanner. It took me a couple of days of flying blind and pondering options to get this job done. I would expect a novice with these instructions to finish the job in under 2 hours.

ENJOY!

Addendum: After finishing this job, I attached the OBD2 scanner and ran Dr. Prius again. It showed that error code P0A050 was still stored in the system and allowed me to clear it.
ukrkoz likes this.

Last edited by billbmsn; 12-28-2018 at 05:32 PM.
billbmsn is offline  
The Following User Says Thank You to billbmsn For This Useful Post:
tferrio (12-26-2018)
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-27-2018, 12:10 PM
Moderator
 
ukrkoz's Avatar
 
Join Date: Jun 2010
Location: Pac NW
Posts: 5,249
Mentioned: 19 Post(s)
Tagged: 1 Thread(s)
Quoted: 830 Post(s)
Thanks: 52
Thanked 445 Times in 392 Posts
Lifetime Supreme Member
Garage
iTrader Score: 0 reviews
I am turning this into sticky.
Thank you for great job!



ukrkoz is online now  
post #3 of 3 Old 12-27-2018, 12:59 PM Thread Starter
New TN User
 
Join Date: Dec 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Ah, thanks. I've gotten so much helpful information about my cars from this site and others around the Web, I'm glad I could return the favor.

Bill
outside of Phoenix.
ukrkoz likes this.
billbmsn is offline  
Sponsored Links
Advertisement
 
 

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Hybrid Forum > Highlander Hybrid

Bookmarks

Tags
hylander hybrid , inverter coolant pump , p0a05

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome