04 ECM rebuild - Toyota Nation Forum : Toyota Car and Truck Forums
RAV4 2nd Generation (2001-2005) Forum dedicated to the discussion of 2nd generation RAV4

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-01-2018, 01:31 PM Thread Starter
Official TN Member
 
Join Date: Jun 2012
Location: Texas
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
04 ECM rebuild

SIL's rav4 has P0776 this morning and having erratic shifting and very slow off the line, feels like someones holding the brakes. Drove less than 5 miles to a repair shop and the shop said to replace the transmission fluid. Vehicle has 102k miles and original fluid. I've never seen bad trans fluid cause an error code, so I did some poking around and it seems the ECM needs to be repaired with this particular code. I was wondering if anyone has any experience with Check Engine, ECT and if Sergie does repair work for the 2004 RAV4. His website does not list this particular model year. I e-mailed him and tried calling his shop, but did not get a response.

I may stick the ECM back in and go and do the trans fluid drop, but I don't expect that to be the issue. Any insight is appreciated!
bretts is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-01-2018, 01:39 PM
cj1
Senior TN Member
 
Join Date: Jan 2014
Location: calif
Posts: 2,078
Mentioned: 6 Post(s)
Tagged: 1 Thread(s)
Quoted: 372 Post(s)
Thanks: 9
Thanked 192 Times in 189 Posts
iTrader Score: 0 reviews
ECM normally on the bottom of suspects for this code.





Causes for this P0776 transmission code may include:

Defective Pressure Control Solenoid
Dirty or contaminated fluid

Dirty or clogged transmission filter

Defective Transmission Pump

Defective Transmission Valve Body

Restricted hydraulic passages

Corroded or damaged connector

Faulty or damaged wiring Faulty PCM

Read more at: https://www.obd-codes.com/p0776
Copyright OBD-Codes.com
cj1 is offline  
post #3 of 4 Old 09-01-2018, 03:30 PM Thread Starter
Official TN Member
 
Join Date: Jun 2012
Location: Texas
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
reconnect ECM and changed the fluid and started it back up and it shakes like a banshee. rpm slow climbs from 500 to 900. throw it in reverse and it clunks into gear. throw it into drive and you barely feel it. step on the accelerator and it struggles to move the car and when you let of the accelerator RPMs drop back down to 500 and the banshee shaking continues.
bretts is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-14-2018, 08:37 AM Thread Starter
Official TN Member
 
Join Date: Jun 2012
Location: Texas
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
(Thread Starter)
Just a follow up/closure - I sent the ECM to Sergei at Check Engine, Ect in Brooklyn, NY like a bunch of other folks did. Got the ECM back and the car is running fine. The thread below cited the exact same symptoms I was having down to the error code so I took a gamble and went the same route and it paid off. Hopefully this helps someone in the future.

https://www.toyotanation.com/forum/6...le-myself.html
bretts is offline  
The Following User Says Thank You to bretts For This Useful Post:
BamZipPow (09-14-2018)
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > RAV4 Forum > RAV4 2nd Generation (2001-2005)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome