2005 Tundra- clicking relay & dead battery - Toyota Nation Forum : Toyota Car and Truck Forums
Tundra 1st Generation (20002006) Looking for dedicated discussion for the 1st Generation of the Toyota Tundra? This forum is the place for you.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-01-2014, 10:53 AM Thread Starter
New TN User
 
Join Date: Apr 2014
Location: James Island
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
2005 Tundra- clicking relay & dead battery

My Tundra ran fine yesterday. Last night I went to get something out of the truck and before I got to it I noticed the running board lights were flashing. Once I got closer I heard a clicking- about one click a second. I opened the hood and could feel a few of the relays clicking. The click and lights were in sync/rhythm with each other. The battery was dead and it only took about an hour or two to drain it. I disconnected the battery to stop the pain...

I was going to charge the battery and hook an OBD II sensor to it to see if anything popped up.

Other than that, does anyone have any thoughts?

Thanks.
Sea Goat is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Tundra Forum > Tundra 1st Generation (20002006)

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome