Please help - Toyota Nation Forum : Toyota Car and Truck Forums
Previa Forum Discussion area for the (discontinued) Toyota Previa.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-15-2019, 07:19 AM Thread Starter
New TN User
 
Join Date: May 2019
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
(Thread Starter)
Please help

What am i missing hiw do i get the plug leads to lock on my coil one was broken of and ive never seen leads like this . Youtube is no help. I just cannot get them to lock on
Attached Thumbnails
Click image for larger version

Name:	20190615_162311_1560601229478.jpg
Views:	21
Size:	369.8 KB
ID:	242836  
Gina Dovey is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-17-2019, 12:47 PM
Cressida nut
 
kamesama980's Avatar
 
Join Date: Jan 2006
Location: Columbus, IN
Posts: 4,578
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Thanks: 2
Thanked 307 Times in 291 Posts
Garage
iTrader Score: 0 reviews
Align the locking tab (on the bottom in your photo) with the locking catch on the distributor cap.

-Russell
"You don't get to judge me for how I fix what you break"
'15 Toyota Prius
'05 Subaru Baja Turbo
'95 Toyota Previa
'70 VW Bug
kamesama980 is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota Nation Forum : Toyota Car and Truck Forums > Toyota Truck, SUV and Van Forums > Previa Forum

Bookmarks

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome