Toyota Nation Forum : Toyota Car and Truck Forums - Blog Entries
Old

More suitable

Posted 04-09-2014 at 11:45 PM by ILLGotti

So, this is my first post. This is kind of a test without much content. The reason I am starting this is because the forums seems to be a little bit more in the 'question and answer' format, which is fine.. However, I tend to fix things on my own and fabricate and I'd like to share that in a more suitable area - the forum is really segregated to type of car, and a lot of things I might want to talk about might very well carry over to any car. Also, I like to provide a lot of pictures and write posts...
ILLGotti's Avatar
Salvage96TercelRebuild
Posted in Uncategorized
Views 73171 Comments 2 ILLGotti is offline
Old

too much oil in my corolla 2004 182k miles

Posted 12-15-2013 at 12:58 PM by edwincabrera

I accidentally put way too much oil in my corolla, aprox 5 liters of oil. when i started the car it wasnt giving out white smoke from the tailpipe. but when I put it in gear and drove it around the block at normal speed, it started blowing out thick white smoke and it smelled like burnt oil. when I accelerated the engine started knocking and rattling. i drained about 6 quarts of oil out the engine and let it burn some of the oil away but when i drove it again the thick white smoke was coming out...
New TN User
Posted in Uncategorized
Views 80361 Comments 0 edwincabrera is offline
Old
Rating: 3 votes, 1.00 average.

2001 Toyota Avalon

Posted 07-21-2013 at 12:40 PM by grannyblackwell

I have a 2001 Toyota Avalon with approx. 180000. miles regular maintenance has been done on the vehicle. recently I have been having trouble with starting and getting the engine to idle, rpm's not high enough to run the ac changed the fuel filter cleaned the mass air flow sensor and throttle body. still having trouble with starting and idling runs great and ac works great when out on highway.
any help would be appreciated.
New TN User
Posted in Uncategorized
Views 71288 Comments 1 grannyblackwell is offline
Old

Liquid Intelligence 245 (Been a while)

Posted 05-11-2013 at 10:09 PM by Northish

So It's been a solid month or so since I've posted anything, been busy with work and fixing the motorcycles, just got my CBR back on the road

Last time I posted the Vienta had a blown head gasket and it was basically unable to be driven due to the fact it would overheat in a matter of minutes and it had a rough as all hell idle. As I had another engine I wasn't too fussed over this so I didn't want to take it in for a repair as that would be costly and I'm as close to broke as...
Northish's Avatar
Goose
Posted in Uncategorized
Views 69054 Comments 0 Northish is offline
Old

Bad news :(

Posted 04-03-2013 at 01:07 AM by Northish
Updated 04-03-2013 at 01:09 AM by Northish

Just a little update, turns out I have a blown headgasket which is why the cooling system doesn't hold pressure, ran the car while it was cold and watched the bubble form under the radiator cap. Since this engine is going to be pulled out hopefully in a few months I'm going to try out one of those quick, cheap fixes. Came across "liquid intelligence 245 Blown headgasket repair" online and decided I'd order some to see how it goes. Might do a write up incase anyone else has come across...
Northish's Avatar
Goose
Posted in Uncategorized
Views 42671 Comments 1 Northish is offline
For the best viewing experience please update your browser to Google Chrome