Toyota Nation Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. Corolla 8th Generation (1998-2002)
    I have a 2000 Toyota corolla LE (automatic) that recently is having some acceleration issues. When i first start pressing the gas it hesitates/jumps before it will go. Also does this when i have to stay around 45-50 and sometimes even at 65. It has had a misfire code since i got it at auction...
  2. Corolla 7th Generation (1993-1997)
    Hi all, So I have a 1993 corolla 1.8L 7AFE, I have an intermittent no spark issue and while I'm searching through old posts to try and find if anyone has exactly what I'm running into I wanted to get this thread started in the event I can't figure it out by myself from reading & testing. Was...
  3. Tercel, Paseo, Starlet, and Sera Forum
    My key got stuck in the ignition on ACC. My mechanic stated that I need a new 'ignition switch housing'. I have searched online and can't find a part called that. All I see is the ignition switch and lock cylinder. The mechanic said this is the piece behind the cylinder. Has anyone heard of this...
  4. General Lexus Discussion
    Has anyone had an issue like this?.. Intermittent starting problem goes like this. Put key in ignition, turn to start, electrics all come on..steering wheel extends as usual and all appropriate lights come on etc. but no engine. So.. turn off, take key out, steering column ret racts, wiggle...
  5. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    I have been working on the car for a while now and i have the engine installed w/ all connections made and timing set and reset. It still wont start. I have pulled the spark plugs out and all of them are wet. New spark plug wires and the coils packs read 13.7k ohms I don't know what to do now...
  6. Celica Forum
    I have a 1995 Celica that I've owned about 6 months. Great car until it broke down last week. It's an automatic and it spluttered to a stop as I was pulling into a car park (how polite). I've traced the problem to the ignition not creating a spark (removed and observed spark plug while...
  7. T-100 Forum
    hello all, my little brother drives a '96 T-100, extended cab, auto, RWD. its completely stock, but recently he calls me up and tells me there's a problem:eek: i drove that thing everywhere and i loved it. so naturally, i get antsy and i ask him, "what did you DO!?!" he says, " when i turn it...
1-7 of 7 Results
Top