Toyota Nation Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 89 Results
  1. Avalon 2nd Generation (2000-2004)
    I had this code and my car had lost power, acceleration was slow. I saw all kinds of suggested fixes on this forum, from spark plugs to VVT solenoid/OCV... For me it was a bad catalytic converter. Check to see it your car is breathing properly! Backed up exhaust can choke the engine and cause...
  2. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    Okay so about a month back I had a code pop up for random misfire along with a code with something that dealt with the purge valve solenoid, a few months before that I had hit something on the freeway and I noticed my exhaust had been bent and the area around the O2 sensor was cracked, I have...
  3. Corolla 9th Gen/1st Gen Matrix (2003-2008)
    Good day all, Trust you'all are well. My corolla has been jerking intermittently and now misfiring. I have just done the motor 4 months back due to the millage being 500000kms. Upon troubleshooting, I noticed the timing chain worn out, thus I bought OEM chain, but to no luck. I then replace...
  4. Avalon 2nd Generation (2000-2004)
    Hello everyone Let me start of by stating the car and recent repairs: I have a 2001 Avalon XLE. Around 289k miles and absolutely zero rust. Not like it matters but I have replaced the battery, radiator, alternator serpentine belt, PS belt, and last and most important the 2 VVT solenoids on...
  5. Pre-88 Toyota Pickup/Hilux
    Hi guys, new here. Tried the search bar but couldn't find anything similar. If anyone knows of a similar thread please point me in that direction. I got a pretty rusty 86 22r pickup from an old guy in my neighborhood. He only drove it one month out of the year for hunting. I test drove it with...
  6. Camry 5th and 6th Gen '02-'11, Solara '04-'08
    First time caller, long time listener. Three months ago, I replaced the leaking valve cover gasket on my car. The motor started sounding really bad and clunking while going about 35mph. It also showed a blinking check engine code. I got it to limp home so I could read read the codes: P0302...
  7. Tacoma 1st Generation (1995.5–2004)
    A little history... 98 Tacoma SR5 3.4L 5VZ-FE - 264,300miles - Truck sat for 10yrs after timing belt, water pump, tensioner/pulley, etc all was replaced, driven for 4-6 weeks, all good. Job changed, it sat... Last year, got in, no ignition, went thru the whole thing, replaced it all, even...
  8. Celica Forum
    hey all, I have a 1991 Celica GT convertible, 5 speed manual, with the 2.2. It was stored since October of last year and recently we pulled it out of storage and noticed the car was missing lightly when it first started but seemed to go away or get better when it was warm. When the car was...
  9. Corolla 10th Gen/2nd Gen Matrix (2009-2013)
    Good: 2010 Corolla fell into my lap for a dime. Bad: 260k+ miles, cylinder 2 misfire, limp mode... First thing I did was replace spark plugs and radiator cap, and clear codes (P0302). Drove for almost 2 days without any problems and code didn't come back. ~50 miles. Figuring it was spark plugs...
  10. Corolla 10th Gen/2nd Gen Matrix (2009-2013)
    Hey guys, got myself a slight head scratcher here. I'm thinking I could possibly be other thinking it but just going to post for other opinions. 2010 1.8 Rola 125k on it. It was sitting for bout 10months. Decided I need it running now and when I Parked it, it was perfect. Changed the brakes...
  11. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    So I have an old 99 camry LE 4cyl that's been beaten on for 274,000 miles and at some point probably in the last 50k had a junkyard engine put in. Needless to say, problems with the car are plentiful and I need to replace it. Because I'm underpaid as a result of desperation of the pandemic and...
  12. Corolla 10th Gen/2nd Gen Matrix (2009-2013)
    Hey there! I have a 2009 Corolla LE I bought last night for $1,300 not running. I was able to get it to come to life but it only runs if I have my foot on the gas and dies if I put it in gear or take it off, it makes a weird noise when I rev it in gear, and supplies some white smoke, which it...
  13. Corolla 8th Generation (1998-2002)
    Hi all, I just recently got a new 'yota to add to the collection. My second day driving it I had hopped on the highway got up to speed (70mph) and was cruising when a felt a slight shake and my check engine light started to flash (Ran perfect before this). When I got home I used my scanner to...
  14. Corolla 8th Generation (1998-2002)
    What's up everyone, trying not to go down the rabbit hole of replacing unnecessary parts here. Please let me know what you think, -The ride starts up fine every time (currently just reached 160K), Usually after it reaches operating temp a few blocks from home and while at a red light it starts...
  15. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    A week ago 2000 Camry 214,000 miles threw code P0300. Plugs, wires, and injector 4 replaced. Other injectors were also cleaned. Started it back up, still had misfire. Was running better tho. Today 2 coil packs and O2 sensor installed. Started back up and threw codes P0135 P0302 P0304. Parts...
  16. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    I have a 2000 Camry Le V6 with a manual transmission and 85k miles. My Camry's check engine light is flashing and after I scanned the car my scan tool displayed P0300, P0302, P0304, P0306. I replaced the front 3 spark plugs and bank 2 upstream O2 sensor and the problem is still there. (I...
  17. Corolla 11th Gen Sedan 2014-19, Scion iM 2016-18
    2017 Toyota Corolla 50th Anniversary Edition - 48,000 miles Hello everyone, This is my first time posting, so I will try to be as concise as possible. Yesterday I was dropping my girlfriend off so she could get to work. We were in a bit of a time crunch so I went straight to her house (with a...
  18. Highlander 1st Generation (2001-2007)
    HI MY MATE & I HAVE A KLUGER WITH A MISFIRE ISSUE. ITS CONSTANT:, MAINLY OCCURS UNDER LOAD ALTHOUGH IDLES A LITTLE ROUGH. HAD A P-0340 CODE (CAMSHAFT POSITION). WEVE DONE TIMING BELT (FULL KIT AND WAS DUE) AND THE RELATED CAM SENSOR. THIS ISSUE IS NOW RESOLVED BUT MISFIRING STILL. NO CODES ARE...
  19. Introduce Yourself Here
    HI MY MATE & I HAVE A KLUGER WITH A MISFIRE ISSUE. ITS CONSTANT:, MAINLY OCCURS UNDER LOAD ALTHOUGH IDLES A LITTLE ROUGH. HAD A P-0340 CODE (CAMSHAFT POSITION). WEVE DONE TIMING BELT (FULL KIT AND WAS DUE) AND THE RELATED CAM SENSOR. THIS ISSUE IS NOW RESOLVED BUT MISFIRING STILL. NO CODES ARE...
  20. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    I'm getting power to my coil packs but there's nothing coming out on the other side. I have put new coils, new wires & new plugs. It ran good for one day and then the next day it wouldn't do nothing and now it's not getting fuel up to the injectors. I put a brand new fuel pump on it and it is...
1-20 of 89 Results
Top