Toyota Nation Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 73 Results
  1. Corolla 9th Gen/1st Gen Matrix (2003-2008)
    every morning it starts up no problem no matter the weather and it seems as long as it sits a while it'll start up perfectly fine. The problem is when I use it throught the day it starts to have these long cranks but not slow cranks and I just have no idea what it can be. I've tried replacing...
  2. RAV4 4th Generation (2013-2018)
    Hi all. I live in Canada Ontario. A bit cold today with only 3 degrees Celcius. This afternoon i warmed up the car for about a minute and took off on the road up to 60kmph which is about 37mph i noticed the rev meter jumped to 3000rpm Is this normal? I thought something was odd or perhaps im...
  3. Celica Forum
    So I recently cleaned my st182 but when I was going for a drive a little bit later the drivers side light wouldn't flip up. I opened the hood to take a look and it was shining, it just wouldn't flip up. anyone here know a fix to this??
  4. Highlander 2nd Gen - Hybrid (XU40/2008-2013)
    My 2008 Highlander Hybrid Limited seems to have lost its a/c and I'm not sure this situation will be humanly survivable as warm weather hits - at least for me! Supposedly the system is charged and holding the coolant (beyond that the dealer threatened they would have to charge by the hour to...
  5. Corolla 10th Gen/2nd Gen Matrix (2009-2013)
    Does anyone else have issues with the fuel pump turning on by itself especially with the Weapon-R Throttle Controller? Car was driving fine the following day, I parked in the garage and heard the fuel pump on with the Weapon-R Throttle Controller. So I turned the keys to the on and off position...
  6. Corolla 10th Gen/2nd Gen Matrix (2009-2013)
    Hello everyone, i have received my cruise control switch and installed it on my 2009 Corolla but when i click on the button to activate it nothing happens. I assumed its not pre-wired so i did a little research and found a method to wire it the problem here is that my A50 connector is different...
  7. Tercel, Paseo, Starlet, and Sera Forum
    hey guys I need some help here. I have recently just broke my bellhousing to my transmission (A55) - and I'm looking to get a new transmission, i just dont know which transmission to get considering i am not finding the exact transmission of my model year. What other transmissions can I use...
  8. Sienna 3rd Generation (2011-2020)
    Hi all! I'm new to the forum. We just bought a '15 Sienna XLE over the weekend. I got the van home and found the RH headrest of the 3rd row seats won't go down with the button. This is keeping me from being able to stow the seat. We're planning on using that cargo space on an upcoming roadtrip...
  9. Camry 5th and 6th Gen '02-'11, Solara '04-'08
    Hey all, I have a 2009 Toyota Camry XLE with the V6 (2GR-FE) engine, and recently I've started hearing chirping noises coming from the belt system on the right side of the engine. I can't figure out what it is exactly, but here is a video of the sound I'm talking about: New video by Zareef Huq I...
  10. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    I have a question regarding the clutch in my Camry. At low speeds, the car can tend to "buck" back and forth, almost bouncy but not vertically, its horizontally. It mainly does is while doing about 15 in a parking lot. It also Tends to have a clicking noise almost like two pennies being slapped...
  11. Prius 1st Gen - Hybrid (1997-2003)
    ..the guys at Autozone and Advanced Auto didn't get any codes because the check engine light wasn't on. The car drives fine but the light is still on and my friend is worried. I'm thinking it could be a faulty/old sensor but my guess is as good as any honeslty. Does anyone have any experience in...
  12. Corolla 9th Gen/1st Gen Matrix (2003-2008)
    Ok a quick backstory to this problem. Last summer I was randomly driving when the check engine light turned on and my toyota matrix lost acceleration and went into LIMP mode. It said it had a ECM problem on the check engine light. Well I just turned off the car, started it back up and didn't...
  13. Scion tC 1st Generation (2005-2010)
    Hello, I’ve recently purchased a 2006 Scion tC with 148k miles that came with a super charger that wasn’t working and hasn’t been working for the past 100k Miles. The previous owner disconnected it by the belt/pulley but it was still connected by the air intake tube. Because of this whenever...
  14. Avalon 4th Generation (2013-2018)
    I just bought a used 2017 avalon with 7k on it. I've been back to the dealer once so far. They road force balanced the tires. That helped on the highway. Now there is still a problem. Driving home each night. After about 30 minutes on the highway (70mph) the speed limit then drops to...
  15. Sequoia Forum
    The stereo went bad on my 2008 and I am hoping you all can help me figure out the broken part. I tried switching out the JBL Amp (86280-0c130), but this did not fix anything (unless the used amp I bought was broken too). Here are the symptoms: 1) Phone works 2) Nav screen works 3) Sound is...
  16. Yaris/Scion iA, Vitz and Echo Forum
    Hey , i have a toyota aygo 2007 model 1.0petrol , currently when the car is still cold its starts and everything is fine , but when its hot the it doesnt want to start and the "STOP" signal keeps flashing , the P/S , ABS , and handbrake signal on the dashboard doesnt go off, its consuming more...
  17. Corolla 9th Gen/1st Gen Matrix (2003-2008)
    Hi, I have a 2005 Corolla and have had very few problems with it. However, right after I hit 200k, the transmission died. I had it replaced but the new one has a few seconds delay between when you put it in drive and when it shifts. Once it is in drive, it shifts fine but I thought I should...
  18. Corolla 11th Gen Sedan 2014-19, Scion iM 2016-18
    Bought the 2017 corrolla XLE, Love the car and features, but the doors were visably mesaligned on the passenger side and there was alot of wind noise in the cabin. Took it to the dealer for repair 3 times. they never acknowledged the problem but the mechanic took a sledge hamer to the door latch...
  19. Corolla 11th Gen Sedan 2014-19, Scion iM 2016-18
    Hi all, I currently own a 2014 Corolla LE(standard entune system 6 speakers) with around 20k miles. I noticed that my left front door speaker did not work. Also the front left door tweeter(attached to the door) emits a faint rendition of music playing. All other speakers/tweeters are working...
  20. Highlander 1st Generation (2001-2007)
    When programming a remote, if the locks cycle twice at the end, that is the signal that the remote DID NOT program properly. I had this problem and tried 10 times failing each. I then learned that if I repeated the last couple of steps several times, eventually it worked --- and gave the...
1-20 of 73 Results
Top