Toyota Nation Forum banner

starting trouble

  1. Pre-88 Toyota Pickup/Hilux
    Car Specs: 1985 Toyota Pickup--22re EFI--2.4liter--Manual 4 speed--165k miles (bought it in 2017 with 93k) Oil & Gas (if it matters): Gas (usually 87 octane, just splashed out on 92 to give the truck a treat and clean out the gunk...ironically just before this trouble started) Oil (usually...
  2. Corolla 9th Gen/1st Gen Matrix (2003-2008)
    Hello there, i'm new to this forum. I have a problem in my 03 toyota matrix XRS, last week my wife went to buy groceries and she left the headlights on, when she came back, car just won't start, she thought that by using jumper cables to start the car will fix the problem, (she didn't have any...
  3. Tundra 2nd Generation (2007-2013)
    Hoping someone has encountered this before. Intermitantly I will turn ignition switch from run position to start position and truck starts and then dies within a few seconds after starting. Returning the ignition switch back to start position causes the starter motor to run however, truck...
  4. Camry 5th and 6th Gen '02-'11, Solara '04-'08
    My daughter has a 2002 Camry 4cyl Auto that will not start if left in the sun. I have replaced battery, starter, starter relay, and cleaned neutral safety switch (also tried moving shifter in Park position). Dealer ran diagnostic and could not find problem, so he suggested replacing the starter...
  5. MR2 Forum
    My 91 mr2 non turbo runs great but after driving it for about 15 miles it will stall and won't restart for 5 to 10 minutes. This is very frustrating because I work on a military base and the gate is right at 15 miles away and today it stalled right as I got to the gate causing a little bit of...
  6. Camry 5th and 6th Gen '02-'11, Solara '04-'08
    Last week the car started but would need the ignition to remain engaged for a couple extra seconds... Today, the car does not start at all. When I turn the key, the car makes a continuous clicking sound and the OIL red light starts flashing. Any ideas? Thanks.
  7. Avalon 1st Generation (1995-1999)
    Sorry, posted in wrong forum
  8. MR2 Forum
    I have a '91 Mr2 Turbo. (3S-GTE) My water pump went out and it took me a good month and a half to get around to fixing it. I changed out the water pump and the timing belt and before putting all the coverings and motor mount back on i tried firing up the car and nothing. All the electrical...
  9. Camry 3rd and 4th Gen '92-'01, Solara '99-'03
    Hello all, I have a '99 Camry with 153K miles on it and current on all maintenance. The car is running fine expect for a starting trouble which is happening more frequently. The batter is brand new. Symptoms: Cold starts are always good. Or starts after couple of hours of long drives are good...
Top