Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just registered after looking through some of this forum for my particular problem without having much luck. I have a 2004 Toyota Tacoma 4 door. The other day I noticed that when the headlights are on the left turn signal stays constant, both front and rear and the turn signal does not work. However, the right side does. When the headlights are off the turn signals work fine on the left and right.

I do have a trailer wire hook up that I purchased from the Toyota dealership and wired myself. However, I put the harness on back in Aprl or May of 2006 and have not had any problems with my lights until now.

Any suggestions would be appreciated.
 

·
boy these trucks are fun
still searching for1
Joined
·
120 Posts
check your fuses and flasher relaysif the fuse goes bad (maybe due to a wiring harness installed on vehicle) it could cause that issue.
 

·
Registered
2002 toyota Tacoma
Joined
·
906 Posts
check around the wiring harness of the left head light and see if there is any bare wires touching. and pull the taillight back out where you put the wiring harness in and check again. make sure the ground is good and no wires are touching. If you still can't find it then try removing the trailer harness and if it goes away then the problem is within the control box for the wiring harness. if it is you can get anew one for about 25.00 at any auto parts store.
Good luck
Lance
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Checked all the fuses and wires and all looked good. I took off the tow harness I bought from Toyota and reconnected the lights to their original connectors and wallah! The lights are now fixed.

:confused: Here is what puzzels me. The tow harness has worked since I put it on several months ago with absolutely no problems whatsoever. Why did it screw up my lights now? Do these things just go bad without any visual evidence?
 

·
Joe
2005 Hilux Tray Top
Joined
·
270 Posts
Lights On

The problem is most likely a short between the tail light and the left indicator at the trailer connector base have good look for wire strands and damaged looms.
Good Luck Joe
 

·
Registered
2002 toyota Tacoma
Joined
·
906 Posts
I had the problem theose control boxes have a circiut card in them and when they malfunction they can cause all kinds of lighting problems like a said before get a new control box from a local automotive and it will spice right in.

Question for you and that is did you try hooking up a trailer to test the lights? If not I bet you would have had problems.

Lance
 
1 - 7 of 7 Posts
Top