Toyota Nation Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hey fellow I'm new here just want to say hello to everyone,
i just recently bought a 91 mr2 turbo, and the oil light stays on for about 4 second everytime when i start the car in the morning, just today i notice that when i start my car when i rev. in neutral i hear a clicking or rattling noise coming from my engine, but it only makes that noise when i rev btw 1200 rpm to 2000 rpm higher than that than it stop, i dont hear that noise while i am driving, only in neutral while the engine is still cold.........if anyone have had this problem or similar situation plesae help me out........
 

·
Premium Member
'91 MR2 Turbo
Joined
·
19,831 Posts
It's very hard to diagnose a noise over the internet. How many miles on your engine? Whens the last time you changed oil? What grade oil are you using?
Always let the engine warm up some before reving engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
the car has 124k mileage on it, the engine still makes that noise even when the engine is warm, but the engine only makes that noise if you press the gas pedel really hard and fast, but if you step softly or as regular driving it doesn't make that noise. I just recently change the oil , about two weeks ago, i use mobil high mileage 10w-40 synthetic......
 

·
Registered
Joined
·
4 Posts
If the sound is going away when you accelerate it could be a pressure problem. If its a pressure problem it could be the oil pump which is wearing out and needs to be replaced, or the tolerances on all the oil passages my have grown overtime from wear, wear which is increased when the engine is run on too little oil, too thin oil, or too thick oil, the latter which is something many people tend to do just because a car has XXX,XXX miles on it to compensate for the previously mentioned tolerance growth.
 
1 - 5 of 5 Posts
Top