Toyota Nation Forum banner

1 - 7 of 7 Posts

·
oh-pin-yun-A-ted
Pickup
Joined
·
1,407 Posts
Discussion Starter #1
my pickup keeps dyin on me! everytime its we outside it starts blowing the EFI fuse and it wont start again unless i let the truck sit overnight and dry and its startin to get under my skin.....i'm assuming that the water is touchin bare wire somewhere and completing a short circuit but i've followed the wiring coming in and out of the fusebox and i see no places where the bare wire is exposed, also, the fusbox has no places that water can enter. am i missing or overlooking something? ill take any tips or advice i can get. thanks a lot
 

·
Banned
Joined
·
2,353 Posts
a guy in a recent post had this problem wet or not, it was due to the o2 sensor wire that was bare and shoorting out on the frame. it usually makes xontact with the driveshaft or other hot or moving parts. if not that check your harness everywhere else
 

·
oh-pin-yun-A-ted
Pickup
Joined
·
1,407 Posts
Discussion Starter #3
i never thought of that. but ill definatley check it out. i just went and tried to start it anout an hour ago and it blew my last three fuses....are there any other wires that would cause that fuse to blow if it gets wet?
 

·
Banned
Joined
·
2,353 Posts
the only thing that i can think moisture intrusion could do is cause corrosion. the voltages arent really high enough to do any damage otherwise. the whole harness check it thoroughly. maby if you run the wipers its possibly causing a wire to short? (just one of the many possibilities) maby if you run the heater or defroster is actually causing it, i know i use the defrost when it rains. i knoiw the blower motor is close to the computer and wiring harenss. like i said just ideas most likely its your harness.
 

·
oh-pin-yun-A-ted
Pickup
Joined
·
1,407 Posts
Discussion Starter #5
well it turns out that there was about one and a half feet of wire under the bed that had burnt and exposed spots and whenwater got in there, it completed the short circuit. so its runnin good now.
 

·
Banned
Camry / 2WD Pickup
Joined
·
601 Posts
Jake,

Any idea what the wire was for? I'm curious about why your EFI fuse was blowing.

Thnx!
 

·
oh-pin-yun-A-ted
Pickup
Joined
·
1,407 Posts
Discussion Starter #7
well im not too sure what the wire was for. the mechanic tried to explain it but i really just wanted to leave. i hate paying for work, but i have no garage (not even a driveway). but i think i recall him saying something about that wire being involved with something to do with the fuel pump, and my roomate says that the fuelpump is in the gas tank, AND that wire is right between the tank and the fuse box. so it makes sense to me.
 
1 - 7 of 7 Posts
Top