Toyota Nation Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ok I have a 1993 Toyota Camry xle v6 is was running fine and all of a sudden it just shut off and when I turn it back on it well just die and I turn it back on and give it gas and as soon as I let go the gas pedal it will shut off and die can any one tell me what is the problem plz and thank u
 

·
Super Moderator
Joined
·
13,664 Posts
So, it’ll stay running as long as you give it some throttle? And it runs ok, except for that?

My first guess is the IAC valve is bad. It controls the idle RPM.
 

·
Super Moderator
Joined
·
13,664 Posts
You can try cleaning it. They get gummed up with soot and start sticking. Best to remove it and disassemble it.
 

·
Super Moderator
Joined
·
13,664 Posts
Here’s a pic showing where it is, up against the firewall on the driver’s side. It’s the black cylinder to the right of my hand, tucked in the crook of the rubber hose. There are 3 (I think?) screws holding it in place, along with a couple of coolant hoses, and an air hose.

 

·
Super Moderator
Joined
·
13,664 Posts
Another pic with it circled in blue. The air hose has been removed in this picture.

 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Now it Warmed up a little bit it’s Bogging out now what do think it could be thanks for the help
 

·
Super Moderator
Joined
·
13,664 Posts
So you’ve cleaned that IAC valve and it’s idling ok, but now the engine bogs?
 

·
Super Moderator
Joined
·
13,664 Posts
So it still won’t idle?

Could be the EGR valve is stuck open, or the EGR vacuum modulator is faulty, and sending vacuum to the EGR valve when it shouldn’t be. Try disconnecting the rubber vacuum line to the EGR valve and plugging the line.
 
1 - 12 of 12 Posts
Top