Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello. I recently acquired this vehicle. Has approx 155k on it. I say approx cause the title states odo discrepancy. So keep that in mind. The car also came with quite a bit of history of work that's been done. From all the stuff I have it seems to have had every scheduled maintenance done from day 1 to about 65k miles(1995). It also had a diary of what was done and how much, mileage etc.after that. It seems someone else bought the car and had this diary of the things done. Just didnt bring it to a dealer. Also says the ecu was replaced at 127k (2010) I guess thats where the odo became incorrect..Theres also a note in 2013 (129k) that the timing belt, water pump, fuel injection, plugs, brake fluid flush, serp belt, cooling flush, cap wires and plugs were done.Glad they did that it cost them $3300 ...Anyway. When I first got the car in March I was apprehensive as to keeping it. My other car died and I basically fell into this one. Also the very 1st time I ever floored the car it took off like a rocket but left a mile long black smoke screen behind me. The second time I did that a few days later there was a smaller cloud. Then after that, it dosent smoke anymore. I assume the older person that used to drive it never used more than 1 inch of the pedal..In town driving thats all you ever need anyway. And it may have sat for a yr. I also did an oil change, it was pretty bad, and the trans fluid seems to be okay. that was done at 125k and is red. My focus was slipping and I changed the trans fluid, that wasnt red anymore and it fixed the slipping.

(1) Soon after I got it I noticed the air suspension would go flat over night on 'normal' setting. I found that if I leave it on 'high' 75% of the time it would stay inflated. So that leads me to believe theres some kind of valve on the pass rear 'strut/bag' that dosent function properly all the time, I can drive, park and theres a 25% chance you can hear it leaking like a flat tire. dont know if anyone can help with that one.Wanted to know what I'm looking for before i take the tire off..

(2) The instrument panel at times turns into a christmas tree. (2.1) This instance is the red circle with the 6 'blocks' around it, I havent found much on that one. BUT I suspect its related to the air suspension. It's also annoying at night. When its off the dimmer works fine. but as soon as I get full light from the dash lights then the red indicator comes on (1 minute later) and the dimmer stops working. (2.2) for no reason the trac and cel will come on. Stay on for a little while then just go out.
I attempted the odb1 code check. cel = 25, abs=54. and during the process got 52,73 from the height light.

Also I get this chatter sometimes when it up shifts from overdrive to 3rd.
And just recently theres been an acceleration delay (?) you can floor it, it wants to go.. but its like its getting too much or not enough of something.. If you feather the pedal back the speed increases and it will begin to accelerate faster.

Don't give me a hard time about flooring the car, I would rather find out somethings broken now than be surprised later. It's possible I pushed some 25 year component to failure. But .. It is 25 years old. This is the oldest car I have ever owned and is almost in pristine condition. almost.
So sense you guys have had 25 years to figure out this car it should be easy for you.... Right? :smile:
Thanks ahead of time.
 

·
Nothings better!
Joined
·
224 Posts
I would recommend doing a routine maintenance like fuel filter and spark plugs and obviously filled with premium most likely the shifting problem is not a transmission issue it's probably a misfire it happens it's an old car and then see how it runs after that. But you know I'm always open to buying it from you!😁
 
1 - 2 of 2 Posts
Top