Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My g/f's 1994 MR2 is pretty much bone stock and recently is running low at idle. Normally around 1200 RPM it dips as low as 800 sometimes and is affected a lot by the AC being on or pressing on the brakes.

Reading other posts, it looks like it could be the O2 sensor. Any other thoughts or should I just replace that first? Any links to an engine diagram or instructions on replacement? Never worked on a mid-engine.
 

·
Premium Member
Joined
·
5,005 Posts
how many kms are on the car??.....when was the last time it had a tune up??......


btw....lucky dude...ur girl drives a 94.....:thumbup:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I'm thinking it is around 160k miles or so.. not sure on any of the previous service. What other service items could cause a low idle but otherwise normal operation? It starts easily.. all other systems seem to work fine, runs smooth.

Haha.. thanks, she is a car freak if nothing else :D
 

·
Registered
Joined
·
1 Posts
1200rpm is actually high. 800rpm sounds right to me. With AC on, it should go up, not down. Check throttle linkage, 02 sensor, or vacuum leaks, esp if its a turbo.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
At 800ish it struggles to keep running...so obviously it's not getting the right air/fuel to keep running smoothly. If 800 is a normal RPM for idle, then it is also idling high.

Yup, it is a turbo so guess we need to check for that also.
 

·
Registered
Joined
·
1 Posts
you can try resetting the ECU and see what happens.. it could also be the AFM.

aside: How many posts do i need before I become a non 'noob' ? can't seem to edit that on this forum. oh well.
 

·
Noobie With A Dream
1993 MR2 Turbo
Joined
·
151 Posts
I have a '91 turbo that's doing the exact same thing. Although, it just started a couple months ago, and nothing has been done to the car for about a year. I cleaned out the throttle body the best I could, but it didn't seem to change anything. I can't figure out what it could be.
 

·
Registered
Joined
·
123 Posts
The correct idle is about 800 RPM for a warm motor. (I always made mine a bit higher to get some cooling at idle.)

The BGB states that the idle should be the same with the A/C on. Assuming that a '94 is the same as a '91-'93, there is an A/C "Idle Up VSV" that bypasses air around the throttle plate to compensate for the load of the compressor.

If the idle is at 1200 on a warm motor, you need to look into why that is. The idle should be about 800 when the E1 and TE1 terminals are shorted together in the Diagnostic connector.
 

·
'87 Mr2 Growler
1987 Mr2
Joined
·
48 Posts
My car idles when you have it in neutral...1500RPM. but when you shift to 1st gear, it runs and it doesn't idle anymore... but it has no A/C .
 
1 - 11 of 11 Posts
Top