Toyota Nation Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So this is an odd one. Hopefully someone can point me in the right direction.

Car details:
1995 Camry LE 4cyl
88k on the odometer.
Automatic

When I accelerate, the car is fine, but when i let off the accelerator, the speedometer suddenly drops to 0 and the transmission seems to disengage (car keeps rolling of course).
Once I throttle again, the speedometer comes back alive and the gears engage again (intermittently though).
This usually happens when the car is cold.

I've never seen anything like this and I've no clue where to start looking
so any help is appreciated, thanks!
 

·
Banned
Car
Joined
·
417 Posts
So this is an odd one. Hopefully someone can point me in the right direction.

Car details:
1995 Camry LE 4cyl
88k on the odometer.
Automatic

When I accelerate, the car is fine, but when i let off the accelerator, the speedometer suddenly drops to 0 and the transmission seems to disengage (car keeps rolling of course).
Once I throttle again, the speedometer comes back alive and the gears engage again (intermittently though).
This usually happens when the car is cold.

I've never seen anything like this and I've no clue where to start looking
so any help is appreciated, thanks!
 

·
What Toyota?
2008 Saab 9-3
Joined
·
10,476 Posts
^ That has nothing to do with this problem. It's gonna be something in the transmission. Wait for someone else to chime in.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Thanks for that too but if the throttle body were dirty, then the idle would be rough/bouncy but this is not the case. it throttles fine and idle is smooth.

I was thinking VSS but there are no check engine codes popping up.

I haven't checked the fluid level on the transmission case, would that cause any weird things like this?
 

·
Registered
Joined
·
26 Posts
this sounds like it may be a couple problems pretending to be one. first thing i would do is adjust throttle valve on the tranny..really trail and error to see if you can make a difference. the speedo problem could be a few different things
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top